summaryrefslogtreecommitdiffstats
path: root/debian/patches/dont-rebuild-install.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/dont-rebuild-install.patch')
-rw-r--r--debian/patches/dont-rebuild-install.patch20
1 files changed, 13 insertions, 7 deletions
diff --git a/debian/patches/dont-rebuild-install.patch b/debian/patches/dont-rebuild-install.patch
index a72b006..a9cf7f7 100644
--- a/debian/patches/dont-rebuild-install.patch
+++ b/debian/patches/dont-rebuild-install.patch
@@ -1,6 +1,12 @@
---- a/Makefile
-+++ b/Makefile
-@@ -556,6 +556,8 @@
+Author: Ximin Luo <infinity0@debian.org>
+Description: Prevent spurious rebuilds
+Forwarded: not-needed
+
+Index: wasi-libc/Makefile
+===================================================================
+--- wasi-libc.orig/Makefile
++++ wasi-libc/Makefile
+@@ -577,6 +577,8 @@ include_dirs:
# Remove selected header files.
$(RM) $(patsubst %,$(SYSROOT_INC)/%,$(MUSL_OMIT_HEADERS))
@@ -9,7 +15,7 @@
startup_files: include_dirs
#
# Build the startup files.
-@@ -566,6 +568,8 @@
+@@ -587,6 +589,8 @@ startup_files: include_dirs
mkdir -p "$(SYSROOT_LIB)" && \
mv *.o "$(SYSROOT_LIB)"
@@ -18,7 +24,7 @@
libc: include_dirs \
$(SYSROOT_LIB)/libc.a \
$(SYSROOT_LIB)/libc-printscan-long-double.a \
-@@ -575,6 +579,8 @@
+@@ -596,6 +600,8 @@ libc: include_dirs \
$(SYSROOT_LIB)/libwasi-emulated-getpid.a \
$(SYSROOT_LIB)/libwasi-emulated-signal.a
@@ -27,7 +33,7 @@
finish: startup_files libc
#
# Create empty placeholder libraries.
-@@ -586,6 +592,7 @@
+@@ -607,6 +613,7 @@ finish: startup_files libc
#
# The build succeeded! The generated sysroot is in $(SYSROOT).
#
@@ -35,7 +41,7 @@
# The check for defined and undefined symbols expects there to be a heap
# alloctor (providing malloc, calloc, free, etc). Skip this step if the build
-@@ -687,5 +694,6 @@
+@@ -712,5 +719,6 @@ install: finish
clean:
$(RM) -r "$(OBJDIR)"
$(RM) -r "$(SYSROOT)"