summaryrefslogtreecommitdiffstats
path: root/debian/patches/dont-rebuild-install.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/dont-rebuild-install.patch')
-rw-r--r--debian/patches/dont-rebuild-install.patch37
1 files changed, 21 insertions, 16 deletions
diff --git a/debian/patches/dont-rebuild-install.patch b/debian/patches/dont-rebuild-install.patch
index d69946d..4f309c9 100644
--- a/debian/patches/dont-rebuild-install.patch
+++ b/debian/patches/dont-rebuild-install.patch
@@ -6,34 +6,39 @@ Index: wasi-libc/Makefile
===================================================================
--- wasi-libc.orig/Makefile
+++ wasi-libc/Makefile
-@@ -584,6 +584,8 @@ include_dirs:
- # Remove selected header files.
- $(RM) $(patsubst %,$(SYSROOT_INC)/%,$(MUSL_OMIT_HEADERS))
+@@ -743,12 +743,15 @@ ifeq ($(WASI_SNAPSHOT), p2)
+ > "$(SYSROOT_INC)/__wasi_snapshot.h"
+ endif
+ touch $@
+
startup_files: include_dirs $(LIBC_BOTTOM_HALF_CRT_OBJS)
#
# Install the startup files (crt1.o etc).
-@@ -591,6 +593,8 @@ startup_files: include_dirs $(LIBC_BOTTO
+ #
mkdir -p "$(SYSROOT_LIB)" && \
cp $(LIBC_BOTTOM_HALF_CRT_OBJS) "$(SYSROOT_LIB)"
++ touch $@
+ # TODO: As of this writing, wasi_thread_start.s uses non-position-independent
+ # code, and I'm not sure how to make it position-independent. Once we've done
+@@ -768,6 +771,7 @@ endif
+ endif
+
+ libc_so: include_dirs $(LIBC_SO)
+ touch $@
-+
- libc: include_dirs \
+
+ STATIC_LIBS = \
$(SYSROOT_LIB)/libc.a \
- $(SYSROOT_LIB)/libc-printscan-long-double.a \
-@@ -600,6 +604,8 @@ libc: include_dirs \
- $(SYSROOT_LIB)/libwasi-emulated-getpid.a \
- $(SYSROOT_LIB)/libwasi-emulated-signal.a
+@@ -784,6 +788,7 @@ STATIC_LIBS += \
+ endif
+ libc: include_dirs $(STATIC_LIBS)
+ touch $@
-+
+
finish: startup_files libc
#
- # Create empty placeholder libraries.
-@@ -611,6 +617,7 @@ finish: startup_files libc
+@@ -796,6 +801,7 @@ finish: startup_files libc
#
# The build succeeded! The generated sysroot is in $(SYSROOT).
#
@@ -41,10 +46,10 @@ Index: wasi-libc/Makefile
# The check for defined and undefined symbols expects there to be a heap
# alloctor (providing malloc, calloc, free, etc). Skip this step if the build
-@@ -722,5 +729,6 @@ install: finish
- clean:
+@@ -982,5 +988,6 @@ clean:
+ $(RM) -r "$(BINDING_WORK_DIR)"
$(RM) -r "$(OBJDIR)"
$(RM) -r "$(SYSROOT)"
+ $(RM) -f include_dirs startup_files libc finish
- .PHONY: default startup_files libc finish install include_dirs clean
+ .PHONY: default startup_files libc libc_so finish install include_dirs clean check-symbols bindings