summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-17 16:58:23 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-17 16:58:23 +0000
commitf1fdd0bd4c520f19e6eb43ac2d6494f0849e25aa (patch)
tree4a94982c7be390ee2c8c58f7c93c1f15e3ce3b27
parentReleasing progress-linux version 2022.06.06-2~progress7.99u1. (diff)
downloadwireless-regdb-f1fdd0bd4c520f19e6eb43ac2d6494f0849e25aa.tar.xz
wireless-regdb-f1fdd0bd4c520f19e6eb43ac2d6494f0849e25aa.zip
Merging upstream version 2024.05.08.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
-rw-r--r--Makefile3
-rw-r--r--db.txt211
-rw-r--r--debian-example/control2
-rw-r--r--regulatory.binbin6184 -> 6724 bytes
-rw-r--r--regulatory.dbbin4492 -> 4936 bytes
-rw-r--r--regulatory.db.p7sbin1182 -> 1085 bytes
-rw-r--r--sforshee.key.pub.pem9
-rw-r--r--sforshee.x509.pem17
-rw-r--r--sha1sum.txt2
-rw-r--r--wens.key.pub.pem9
-rw-r--r--wens.x509.pem17
-rw-r--r--wireless-regdb.spec2
12 files changed, 176 insertions, 96 deletions
diff --git a/Makefile b/Makefile
index 02176ec..42ca1e7 100644
--- a/Makefile
+++ b/Makefile
@@ -34,7 +34,7 @@ REGDB_PRIVKEY ?= ~/.wireless-regdb-$(REGDB_AUTHOR).key.priv.pem
REGDB_PUBKEY ?= $(REGDB_AUTHOR).key.pub.pem
REGDB_PUBCERT ?= $(REGDB_AUTHOR).x509.pem
-REGDB_UPSTREAM_PUBKEY ?= sforshee.key.pub.pem
+REGDB_UPSTREAM_PUBKEY ?= wens.key.pub.pem
REGDB_CHANGED = $(shell $(SHA1SUM) -c --status sha1sum.txt >/dev/null 2>&1; \
if [ $$? -ne 0 ]; then \
@@ -69,6 +69,7 @@ regulatory.db.p7s: regulatory.db $(REGDB_PRIVKEY) $(REGDB_PUBCERT)
-signer $(REGDB_PUBCERT) \
-inkey $(REGDB_PRIVKEY) \
-in $< -nosmimecap -binary \
+ -noattr \
-outform DER -out $@
sha1sum.txt: db.txt
diff --git a/db.txt b/db.txt
index 16b38b7..45ec3f3 100644
--- a/db.txt
+++ b/db.txt
@@ -124,20 +124,45 @@ country AT: DFS-ETSI
(57000 - 66000 @ 2160), (40)
# Source:
-# https://www.legislation.gov.au/Details/F2022C00281
+# 'Item' in the comments below refers to each numbered rule found at:
+# https://www.legislation.gov.au/Details/F2023C00524
# Both DFS-ETSI and DFS-FCC are acceptable per AS/NZS 4268 Appendix B.
# The EIRP for DFS bands can be increased by 3dB if TPC is implemented.
# In order to allow 80MHz operation between 5650-5730MHz the upper boundary
# of this more restrictive band has been shifted up by 5MHz from 5725MHz.
country AU: DFS-ETSI
- (2400 - 2483.5 @ 40), (36)
- (5150 - 5250 @ 80), (23), NO-OUTDOOR, AUTO-BW
- (5250 - 5350 @ 80), (20), NO-OUTDOOR, AUTO-BW, DFS
- (5470 - 5600 @ 80), (27), DFS
- (5650 - 5730 @ 80), (27), DFS
- (5730 - 5850 @ 80), (36)
- (5925 - 6425 @ 160), (24), NO-OUTDOOR
- (57000 - 66000 @ 2160), (43), NO-OUTDOOR
+ # Item 58
+ (915 - 920 @ 4), (1000 mW)
+ (920 - 928 @ 8), (1000 mW)
+
+ # Item 59
+ (2400 - 2483.5 @ 40), (4000 mW)
+
+ # Item 61
+ (5150 - 5250 @ 80), (200 mW), NO-OUTDOOR, AUTO-BW
+
+ # Item 62 (200 mW allowed if TPC is used)
+ (5250 - 5350 @ 80), (100 mW), NO-OUTDOOR, AUTO-BW, DFS
+
+ # Item 63(a) (1000 mW with TPC)
+ (5470 - 5600 @ 80), (500 mW), DFS
+
+ # Item 63(b) (1000 mW with TPC)
+ # The end is 5725 but we borrow 5 MHz from the following less restrictive band
+ # so we can get an 80 MHz channel.
+ (5650 - 5730 @ 80), (500 mW), DFS
+
+ # Item 60
+ (5730 - 5850 @ 80), (4000 mW), AUTO-BW
+
+ # Item 22
+ (5850 - 5875 @ 20), (25 mW), AUTO-BW
+
+ # Item 63AA (25 mW if outdoors)
+ (5925 - 6425 @ 160), (250 mW), NO-OUTDOOR
+
+ # Item 65
+ (57000 - 71000 @ 2160), (20000 mW), NO-OUTDOOR
country AW: DFS-ETSI
(2402 - 2482 @ 40), (20)
@@ -279,12 +304,21 @@ country BO: DFS-JP
(5250 - 5330 @ 80), (30), DFS
(5735 - 5835 @ 80), (30)
+# Source:
+# https://www.gov.br/anatel/pt-br/regulado/radiofrequencia/radiacao-restrita
+# https://informacoes.anatel.gov.br/legislacao/resolucoes/2017/936-resolucao-680
+# https://informacoes.anatel.gov.br/legislacao/atos-de-certificacao-de-produtos/2017/1139-ato-14448
country BR: DFS-FCC
- (2402 - 2482 @ 40), (20)
- (5170 - 5250 @ 80), (17), AUTO-BW
- (5250 - 5330 @ 80), (24), DFS, AUTO-BW
- (5490 - 5730 @ 160), (24), DFS
- (5735 - 5835 @ 80), (30)
+ (2400 - 2483.5 @ 40), (30)
+ # The next three ranges have been reduced by 3dB, could be increased
+ # to 30dBm if TPC is implemented.
+ (5150 - 5250 @ 80), (27), NO-OUTDOOR, AUTO-BW
+ (5250 - 5350 @ 80), (27), NO-OUTDOOR, DFS, AUTO-BW
+ (5470 - 5725 @ 160), (27), DFS, AUTO-BW
+ (5725 - 5850 @ 80), (30), AUTO-BW
+ (5925 - 7125 @ 320), (12), NO-OUTDOOR, NO-IR
+ # EIRP=40dBm (43dBm peak)
+ (57000 - 71000 @ 2160), (40)
country BS: DFS-FCC
(2402 - 2482 @ 40), (20)
@@ -349,8 +383,10 @@ country CH: DFS-ETSI
(5470 - 5725 @ 160), (500 mW), DFS, wmmrule=ETSI
# short range devices (ETSI EN 300 440-1)
(5725 - 5875 @ 80), (25 mW)
- # 60 GHz band channels 1-4 (ETSI EN 302 567)
- (57000 - 66000 @ 2160), (40)
+ # https://www.ofcomnet.ch/api/rir/1010/11
+ (5945 - 6425 @ 160), (200 mW), NO-OUTDOOR, wmmrule=ETSI
+ # https://www.ofcomnet.ch/api/rir/1010/07
+ (57000 - 71000 @ 2160), (40)
country CI: DFS-FCC
(2402 - 2482 @ 40), (20)
@@ -367,10 +403,11 @@ country CL: DFS-JP
# Source:
# https://wap.miit.gov.cn/cms_files/filemanager/1226211233/attach/20219/d125301b13454551b698ff5afa49ca28.pdf
+# https://www.miit.gov.cn/cms_files/filemanager/1226211233/attach/20236/d1dc19424d5a4cfe90d631adeee8dd58.pdf
# Note: The transmit power for 5150-5350MHz bands can be raised by 3dBm when TPC is implemented
country CN: DFS-FCC
(2400 - 2483.5 @ 40), (20)
- (5150 - 5350 @ 80), (20), DFS, AUTO-BW
+ (5150 - 5350 @ 80), (20), DFS, AUTO-BW, NO-OUTDOOR
(5725 - 5850 @ 80), (33)
# 60 GHz band channels 1,4: 28dBm, channels 2,3: 44dBm
# ref: http://www.miit.gov.cn/n11293472/n11505629/n11506593/n11960250/n11960606/n11960700/n12330791.files/n12330790.pdf
@@ -564,11 +601,12 @@ country EE: DFS-ETSI
# 60 GHz band channels 1-4 (ETSI EN 302 567)
(57000 - 66000 @ 2160), (40)
-# https://www.tra.gov.eg/en/industry/importing-of-equipment/Pages/Regulations-for-use-of-Wireless-Networks-Devices.aspx
+# https://www.tra.gov.eg/wp-content/uploads/2022/03/EGY-NTRA-March-2022-SRD_English_Final.pdf
country EG: DFS-ETSI
(2402 - 2483.5 @ 40), (20)
- (5150 - 5250 @ 80), (23), NO-OUTDOOR, AUTO-BW, wmmrule=ETSI
- (5250 - 5330 @ 80), (20), NO-OUTDOOR, DFS, AUTO-BW, wmmrule=ETSI
+ (5150 - 5250 @ 80), (23), AUTO-BW, wmmrule=ETSI
+ (5250 - 5350 @ 80), (20), DFS, AUTO-BW, wmmrule=ETSI
+ (57000 - 66000 @ 2160), (40)
# ES as part of EU/CEPT accepted decisions 2005/513/EC (5GHz RLAN, EN 301 893)
# and 2006/771/EC (amended by 2008/432/EC, Short-Range Devices, EN 300 440)
@@ -732,14 +770,21 @@ country GU: DFS-FCC
country GY:
(2402 - 2482 @ 40), (30)
+ (5170 - 5250 @ 80), (23), AUTO-BW
+ (5250 - 5330 @ 80), (23), DFS, AUTO-BW
+ (5490 - 5730 @ 160), (23), DFS
(5735 - 5835 @ 80), (30)
+# Source:
+# https://www.ofca.gov.hk/filemanager/ofca/en/content_401/hkca1039.pdf (2.4 GHz and 5 GHz)
+# https://www.ofca.gov.hk/filemanager/ofca/en/content_401/hkca1081.pdf (6 GHz)
country HK: DFS-ETSI
- (2402 - 2482 @ 40), (20)
- (5170 - 5250 @ 80), (17), AUTO-BW
- (5250 - 5330 @ 80), (24), DFS, AUTO-BW
- (5490 - 5710 @ 160), (24), DFS
- (5735 - 5835 @ 80), (30)
+ (2400 - 2483.5 @ 40), (36)
+ (5150 - 5250 @ 80), (23), AUTO-BW, NO-OUTDOOR
+ (5250 - 5350 @ 80), (23), DFS, AUTO-BW, NO-OUTDOOR
+ (5470 - 5730 @ 160), (27), DFS
+ (5730 - 5850 @ 80), (36)
+ (5925 - 6425 @ 160), (14)
country HN: DFS-FCC
(2402 - 2482 @ 40), (20)
@@ -836,11 +881,14 @@ country IL: DFS-ETSI
# Table B List of conditions, row 68, wireless device using 802.11a/n/ac protocol
(5725 - 5875 @ 80), (200 mW), AUTO-BW
+# Source:
+# https://dot.gov.in/spectrummanagement/delicensing-24-24835-ghz-band-gsr-45-e-5150-5350-ghz-gsr-46-e-and-5725-5875-ghz
+# https://dot.gov.in/spectrummanagement/license-exemption-5-ghz-gsr-1048e-dated-22102018
country IN:
- (2402 - 2482 @ 40), (20)
+ (2402 - 2482 @ 40), (30)
(5150 - 5250 @ 80), (30)
- (5250 - 5350 @ 80), (24)
- (5470 - 5725 @ 160), (24)
+ (5250 - 5350 @ 80), (24), DFS
+ (5470 - 5725 @ 160), (24), DFS
(5725 - 5875 @ 80), (30)
country IR: DFS-JP
@@ -893,13 +941,18 @@ country JO: DFS-JP
(5170 - 5250 @ 80), (23)
(5735 - 5835 @ 80), (23)
+# Source:
+# https://www.soumu.go.jp/main_content/000635492.pdf
+# https://www.soumu.go.jp/main_content/000833682.pdf
+# https://www.soumu.go.jp/main_content/000919158.pdf
country JP: DFS-JP
(2402 - 2482 @ 40), (20)
(2474 - 2494 @ 20), (20), NO-OFDM
(4910 - 4990 @ 40), (23)
(5170 - 5250 @ 80), (20), AUTO-BW
(5250 - 5330 @ 80), (20), DFS, AUTO-BW
- (5490 - 5710 @ 160), (23), DFS
+ (5490 - 5730 @ 160), (23), DFS
+ (5925 - 6425 @ 320), (200 mW), NO-OUTDOOR
# 60 GHz band channels 2-4 at 10mW,
# ref: http://www.arib.or.jp/english/html/overview/doc/1-STD-T74v1_1.pdf
(57000 - 66000 @ 2160), (10 mW)
@@ -1349,18 +1402,34 @@ country PG: DFS-FCC
(5490 - 5730 @ 160), (24), DFS
(5735 - 5835 @ 80), (30)
+# NTC MC 09-09-2003 https://ntc.gov.ph/wp-content/uploads/2015/10/LawsRulesRegulations/MemoCirculars/MC2003/MC-09-09-2003.pdf
+# NTC MC 03-05-2007 https://ntc.gov.ph/wp-content/uploads/2015/10/LawsRulesRegulations/MemoCirculars/MC2007/MC-03-05-2007.pdf
+# NTC MC 03-08-2013 https://region7.ntc.gov.ph/images/LawsRulesAndRegulations/MC/WDN/MC_03-08-2013.pdf
+# NTC MC 01-01-2016 https://ntc.gov.ph/wp-content/uploads/2016/MC/Explanatory-MC-No-01-01-2016.pdf
+# 2400 - 2483.5 MHz: NTC MC 09-09-2003, Section 3.1; NTC MC 03-08-2013, Section 3.1; NTC MC 03-05-2007, Section 2
+# 5150 - 5350 MHz: NTC MC 09-09-2003, Section 3.1; NTC MC 03-08-2013, Section 3.1; NTC MC 03-05-2007, Section 2
+# 5470 - 5850 MHz: NTC MC 09-09-2003, Section 3.1; NTC MC 03-08-2013, Section 3.1 NTC MC 03-05-2007, Section 2
+# 57000 - 66000 MHz: NTC MC 01-01-2016, Section 1
+
country PH: DFS-FCC
- (2402 - 2482 @ 40), (20)
- (5170 - 5250 @ 80), (17), AUTO-BW
- (5250 - 5330 @ 80), (24), DFS, AUTO-BW
- (5490 - 5730 @ 160), (24), DFS
- (5735 - 5835 @ 80), (30)
+ (2400 - 2483.5 @ 40), (20)
+ (5150 - 5250 @ 80), (23), AUTO-BW
+ (5250 - 5350 @ 80), (23), DFS, AUTO-BW
+ (5470 - 5725 @ 160), (24), DFS
+ (5725 - 5850 @ 80), (24)
+ (57000 - 66000 @ 2160), (24)
country PK: DFS-JP
# https://fab.gov.pk/type-approval/
# https://pta.gov.pk/media/Pakistan_Table_of_Frequency_Allocations.pdf
- (2402 - 2482 @ 40), (20)
- (5725 - 5875 @ 80), (30)
+ # https://www.pta.gov.pk/assets/media/iot_srd_regulatory_framework_01-06-2022.pdf
+ (2402 - 2482 @ 40), (100 mW)
+ (5150 - 5270 @ 80), (200 mW), NO-OUTDOOR, AUTO-BW
+ (5270 - 5350 @ 80), (100 mW), NO-OUTDOOR, DFS, AUTO-BW
+ (5470 - 5610 @ 80), (100 mW), NO-OUTDOOR, DFS, AUTO-BW
+ (5610 - 5725 @ 80), (200 mW), AUTO-BW
+ (5725 - 5875 @ 80), (1000 mW)
+ (57000 - 66000 @ 2160), (40)
# PL as part of EU/CEPT accepted decisions 2005/513/EC (5GHz RLAN, EN 301 893)
# and 2006/771/EC (amended by 2008/432/EC, Short-Range Devices, EN 300 440)
@@ -1476,10 +1545,12 @@ country RS: DFS-ETSI
# 60 GHz band channels 1-4, ref: Etsi En 302 567
(57000 - 66000 @ 2160), (40)
+# Source: https://docs.cntd.ru/document/1300597464?section=text
country RU:
- (2400 - 2483.5 @ 40), (20)
- (5150 - 5350 @ 160), (20), NO-OUTDOOR
- (5650 - 5850 @ 160), (20), NO-OUTDOOR
+ (2400 - 2483.5 @ 40), (100mW)
+ (5150 - 5350 @ 160), (100 mW), NO-OUTDOOR
+ (5650 - 5850 @ 160), (100 mW), NO-OUTDOOR
+ (5925 - 6425 @ 160), (100 mW), NO-OUTDOOR
# 60 GHz band channels 1-4, ref: Changes to NLA 124_Order №129_22042015.pdf
(57000 - 66000 @ 2160), (40), NO-OUTDOOR
@@ -1515,25 +1586,31 @@ country SE: DFS-ETSI
# 60 GHz band channels 1-4 (ETSI EN 302 567)
(57000 - 66000 @ 2160), (40)
-# https://www.imda.gov.sg/-/media/Imda/Files/Regulation-Licensing-and-Consultations/ICT-Standards/Telecommunication-Standards/Radio-Comms/IMDATSSRD.pdf
-# IMDA TS SRD, Issue 1 Revision 1, April 2019, subsequently "IMDA TS SRD"
-# 2400 - 2483.5 MHz: IMDA TS SRD, Table 1 (25); ANSI C63.10-2013 and FCC Part 15 Section 15.247 or EN 300 328
-# 5150 - 5350 MHz: IMDA TS SRD, Table 1 (29); FCC Part 15 Section 15.407 (1) 5.15-5.25 GHz (2) 5.25-5.35 GHz; EN 301 893
-# 5470 - 5725 MHz: IMDA TS SRD, Table 1 (30); FCC Part 15 Section 15.407 (2) 5.47-5.725 GHz; EN 301 893
-# 5725 - 5850 MHz: IMDA TS SRD, Table 1 (27); FCC Part 15 Section 15.247; FCC Part 15 Section 15.407 (3) 5.725-5.85 GHz
-# 57000 - 66000 MHz: IMDA TS SRD, Table 1 (31); ETSI EN 302 567
-# Note: 27dBm for 5470-5725MHz bands is 3dBm reduction per FCC Part 15 Section 15.407 (2) 5.47-5.725 GHz; EN 301 893 as referenced by IMDA TS SRD
+# https://www.imda.gov.sg/-/media/imda/files/regulation-licensing-and-consultations/ict-standards/telecommunication-standards/radio-comms/imdatssrd.pdf
+# IMDA TS SRD, Issue 1 Revision 3, Sep 2023, subsequently "IMDA TS SRD"
+# 2400 - 2483.5 MHz: IMDA TS SRD, Table 1 Sub-band 32e
+# 5150 - 5350 MHz: IMDA TS SRD, Table 1 Sub-band 33a
+# 5470 - 5725 MHz: IMDA TS SRD, Table 1 Sub-band 34
+# 5725 - 5850 MHz: IMDA TS SRD, Table 1 Sub-band 35
+# 5945 - 6425 MHz: IMDA TS SRD, Table 1 Sub-band 45b
+# 57000 - 66000 MHz: IMDA TS SRD, Table 1 Sub-band 40
+# Note: 500mW for 5470-5725MHz bands per FCC Part 15 Section 15.407 (2) 5.47-5.725 GHz as referenced by IMDA TS SRD
# AU and BG regulatory domains use the same interpretation of cited FCC and ETSI standards
-# Note: The transmit power for 5250-5350MHz bands can be raised by 3dBm when TPC is implemented: IMDA TS SRD Table 1 (29)
-# Note: The transmit power for 5470-5725MHz bands can be raised by 3dBm when TPC is implemented: IMDA TS SRD Table 1 (30)
+# Note: The transmit power for 5250-5350MHz bands can be raised (by 3dBm) to 200mW when TPC is implemented: IMDA TS SRD, Table 1 Sub-band 33a
+# Note: The transmit power for 5470-5725MHz bands can be raised (by 3dBm) to 1000mW when TPC is implemented: IMDA TS SRD Table 1 Sub-band 34
country SG: DFS-FCC
- (2400 - 2483.5 @ 40), (23)
- (5150 - 5250 @ 80), (23), AUTO-BW
- (5250 - 5350 @ 80), (20), DFS, AUTO-BW
- (5470 - 5725 @ 160), (27), DFS
- (5725 - 5850 @ 80), (30)
- (57000 - 66000 @ 2160), (40)
+ (2400 - 2483.5 @ 40), (200 mW)
+ (5150 - 5250 @ 80), (200 mW), AUTO-BW
+ (5250 - 5350 @ 80), (100 mW), DFS, AUTO-BW
+ # This range ends at 5725 MHz, but channel 144 extends to 5730 MHz.
+ # Since 5725 ~ 5730 MHz belongs to the next range which has looser
+ # requirements, we can extend the range by 5 MHz to make the kernel
+ # happy and be able to use channel 144.
+ (5470 - 5730 @ 160), (500 mW), DFS
+ (5725 - 5850 @ 80), (1000 mW)
+ (5945 - 6425 @ 320), (250 mW), NO-OUTDOOR
+ (57000 - 66000 @ 2160), (10000 mW)
# SI as part of EU/CEPT accepted decisions 2005/513/EC (5GHz RLAN, EN 301 893)
# and 2006/771/EC (amended by 2008/432/EC, Short-Range Devices, EN 300 440)
@@ -1633,14 +1710,14 @@ country TN: DFS-ETSI
(5250 - 5330 @ 80), (20), DFS, AUTO-BW
# Source:
-# By-Law on Short Range Radio Devices (SRD) Oct 2015
-# https://www.btk.gov.tr/File/?path=ROOT%2f1%2fDocuments%2fOrdinance%2fBY%2DLAW%20ON%20SHORT%20RANGE%20DEVICES.pdf
-# Article 8
+# Technical Criteria for Radio Devices and Systems Excluded from Frequency Allocation, Sept 9, 2022
+# https://www.btk.gov.tr/uploads/pages/ftm-teknik-olcutler-ek-5.pdf
country TR: DFS-ETSI
(2400 - 2483.5 @ 40), (20)
- (5170 - 5250 @ 80), (23), NO-OUTDOOR, AUTO-BW
- (5250 - 5330 @ 80), (20), DFS, NO-OUTDOOR, AUTO-BW
- (5470 - 5725 @ 160), (27), DFS
+ (5150 - 5250 @ 80), (23), NO-OUTDOOR, AUTO-BW, wmmrule=ETSI
+ (5250 - 5330 @ 80), (20), DFS, NO-OUTDOOR, AUTO-BW, wmmrule=ETSI
+ (5470 - 5725 @ 160), (27), DFS, wmmrule=ETSI
+ (5495 - 6425 @ 160), (23), NO-OUTDOOR, wmmrule=ETSI
# 60 GHz band channels 1-4, ref: Etsi En 302 567
(57000 - 66000 @ 2160), (40)
@@ -1655,12 +1732,12 @@ country TT: DFS-FCC
# Table of Frequency Allocations of Republic of China (Taiwan) / Feb 2017:
# https://www.motc.gov.tw/websitedowndoc?file=post/201702221012200.doc& \
# filedisplay=Table%2Bof%2Bradio%2Bfrequency%2Ballocation.doc
-# LP0002 Low-power Radio-frequency Devices Technical Regulations / 23 Aug 2016:
-# http://www.ncc.gov.tw/english/show_file.aspx?table_name=news&file_sn=681
+# LP0002 Low-power Radio-frequency Devices Technical Regulations / 6 Feb 2024:
+# https://www.ncc.gov.tw/chinese/files/24020/538_49880_240206_3.pdf
country TW: DFS-FCC
- # 2.4g band, LP0002 section 3.10.1
+ # 2.4g band, LP0002 section 4.10.1
(2400 - 2483.5 @ 40), (30)
- # 5g U-NII band, LP0002 section 4.7
+ # 5g U-NII band, LP0002 section 5.7
# 5.15 ~ 5.25 GHz: 30 dBm for master mode, 23 dBm for clients
(5150 - 5250 @ 80), (23), AUTO-BW
(5250 - 5350 @ 80), (23), DFS, AUTO-BW
@@ -1670,7 +1747,9 @@ country TW: DFS-FCC
# happy and be able to use channel 144.
(5470 - 5730 @ 160), (23), DFS
(5725 - 5850 @ 80), (30)
- # 60g band, LP0002 section 3.13.1.1 (3)(C), EIRP=40dBm(43dBm peak)
+ # 6g band, LP0002 section 5.13.1.1, EIRP=23dBm
+ (5945 - 6425 @ 320), (23), NO-OUTDOOR
+ # 60g band, LP0002 section 4.13.1.1 (1)(A), EIRP=40dBm(43dBm peak)
(57000 - 66000 @ 2160), (40)
country TZ:
diff --git a/debian-example/control b/debian-example/control
index e6e7161..3d186ee 100644
--- a/debian-example/control
+++ b/debian-example/control
@@ -12,4 +12,4 @@ Suggests: crda
Description: The Linux wireless regulatory database
This package contains the wireless regulatory database used by all
cfg80211 based Linux wireless drivers. The wireless database being
- used is maintained by Seth Forshee.
+ used is maintained by Chen-Yu Tsai.
diff --git a/regulatory.bin b/regulatory.bin
index aab7904..245627d 100644
--- a/regulatory.bin
+++ b/regulatory.bin
Binary files differ
diff --git a/regulatory.db b/regulatory.db
index 1c1131b..5270ec0 100644
--- a/regulatory.db
+++ b/regulatory.db
Binary files differ
diff --git a/regulatory.db.p7s b/regulatory.db.p7s
index 01a1c66..db37680 100644
--- a/regulatory.db.p7s
+++ b/regulatory.db.p7s
Binary files differ
diff --git a/sforshee.key.pub.pem b/sforshee.key.pub.pem
deleted file mode 100644
index 73d580e..0000000
--- a/sforshee.key.pub.pem
+++ /dev/null
@@ -1,9 +0,0 @@
------BEGIN PUBLIC KEY-----
-MIIBIjANBgkqhkiG9w0BAQEFAAOCAQ8AMIIBCgKCAQEAtUDjnCiEOQPyOddmLEE4
-Fax+pYNxJX6QfGjdbz/Z11k4n3xqUsIDKi1+ZvQesxJwIFvUlzI9cYs7GwgXFGth
-xFeLlhYc/STVCwn5aBGE+8pRDNFFGdoQRIrZ/nap/WAtGAsolbIt6oiYuNFWIfBT
-H/ECb+lGm5NfKJAPrDb6aCNxV1b2zNPffSrZG3NF67onhe96f6XLgMcwNtJT7uys
-Hucx8TainGPGZVt/JXVooerTfgBcml7YIBgydwcpEmYeNnPnlwRBN7Gxciv0oSkg
-fJZ5CyvQ2N7IbD+T+8XueFIRFRt69uJomef7RhaE48eh5uDSRtXhxF+gZvTaxP+V
-HQIDAQAB
------END PUBLIC KEY-----
diff --git a/sforshee.x509.pem b/sforshee.x509.pem
deleted file mode 100644
index ebd0160..0000000
--- a/sforshee.x509.pem
+++ /dev/null
@@ -1,17 +0,0 @@
------BEGIN CERTIFICATE-----
-MIICpDCCAYwCCQCyjd9HrvnOpzANBgkqhkiG9w0BAQsFADATMREwDwYDVQQDDAhz
-Zm9yc2hlZTAgFw0xNzEwMDYxOTQwMzVaGA8yMTE3MDkxMjE5NDAzNVowEzERMA8G
-A1UEAwwIc2ZvcnNoZWUwggEiMA0GCSqGSIb3DQEBAQUAA4IBDwAwggEKAoIBAQC1
-QOOcKIQ5A/I512YsQTgVrH6lg3ElfpB8aN1vP9nXWTiffGpSwgMqLX5m9B6zEnAg
-W9SXMj1xizsbCBcUa2HEV4uWFhz9JNULCfloEYT7ylEM0UUZ2hBEitn+dqn9YC0Y
-CyiVsi3qiJi40VYh8FMf8QJv6Uabk18okA+sNvpoI3FXVvbM0999Ktkbc0XruieF
-73p/pcuAxzA20lPu7Kwe5zHxNqKcY8ZlW38ldWih6tN+AFyaXtggGDJ3BykSZh42
-c+eXBEE3sbFyK/ShKSB8lnkLK9DY3shsP5P7xe54UhEVG3r24miZ5/tGFoTjx6Hm
-4NJG1eHEX6Bm9NrE/5UdAgMBAAEwDQYJKoZIhvcNAQELBQADggEBAIcD2vKCwt2v
-fEQvhtNfTJNIuf4HF7sh9yUjTqoiDBa5c66dRnx12cNJV0e/M7eX7PVAdcBGIvCg
-XZx5E6H/uKMve44GP8i25Goo8jRcIz8ywOatD6zPVXRHc9MBhbcLIlYkfZ8JqQ6G
-njdbnG0C2YzIUGriWfMWBuqyQrVY/rrRgVca77I4iFj2qsQui1on5KXopMpnXKxy
-Z8NvE8MtNXnXiuf11CEwStX2o9l5VvIPEPd90FGTL0f4fUsKhFUSCn1OOx8rL/wo
-s2k04YCAu+KvudYw8R1UhyOZn1EDTEV9AmVzq/3PlMwNOmD9PBQvFjOpIR/LULGP
-A+6gZqkWeRQ=
------END CERTIFICATE-----
diff --git a/sha1sum.txt b/sha1sum.txt
index 7865603..1ca7a98 100644
--- a/sha1sum.txt
+++ b/sha1sum.txt
@@ -1 +1 @@
-7ed3866486ee6b403a9a6af1ac267dbd5ddda06a db.txt
+6b087a35018f9c1119572298fbc46ff37943c8d9 db.txt
diff --git a/wens.key.pub.pem b/wens.key.pub.pem
new file mode 100644
index 0000000..7239de9
--- /dev/null
+++ b/wens.key.pub.pem
@@ -0,0 +1,9 @@
+-----BEGIN PUBLIC KEY-----
+MIIBIjANBgkqhkiG9w0BAQEFAAOCAQ8AMIIBCgKCAQEAqXoseE2nGS0yUqAubO+I
+fxXFtmlUFkMUeVO3roj+wLddR44a4e+zkIba02SBH85dnktuWAI+sm9eQkdB9Cy4
+qNSqwA7mSPCozssIrjev9kA5y1VvW0+FNOZpEFByXk6dTLo4Ng3OczjXJwIqeQPh
+rM+wJ4WGkxer7EJ3N2WKRMvWQpOSE+M5RcVuAEp/y0IXKyWMuBc7FTZZ3kLOIea2
+x25eJh/3ileepZZytwIy6wcrc+JPZlia6w8HtqtQi8OPF/oKmcIWJb8taxqq5j5f
+622bXU1Cgy05uMms2zqRUN+7sXZtFXP9xuZrcZ5nNiKDebHWuIRSr5Zbw2MCTnhw
+VwIDAQAB
+-----END PUBLIC KEY-----
diff --git a/wens.x509.pem b/wens.x509.pem
new file mode 100644
index 0000000..5fa4e44
--- /dev/null
+++ b/wens.x509.pem
@@ -0,0 +1,17 @@
+-----BEGIN CERTIFICATE-----
+MIICpzCCAY8CFGHAOGUaq9z5S9Csf/BsckjbGMYAMA0GCSqGSIb3DQEBCwUAMA8x
+DTALBgNVBAMMBHdlbnMwIBcNMjMxMjAxMDc0MTE0WhgPMjEyMzExMDcwNzQxMTRa
+MA8xDTALBgNVBAMMBHdlbnMwggEiMA0GCSqGSIb3DQEBAQUAA4IBDwAwggEKAoIB
+AQCpeix4TacZLTJSoC5s74h/FcW2aVQWQxR5U7euiP7At11Hjhrh77OQhtrTZIEf
+zl2eS25YAj6yb15CR0H0LLio1KrADuZI8KjOywiuN6/2QDnLVW9bT4U05mkQUHJe
+Tp1Mujg2Dc5zONcnAip5A+Gsz7AnhYaTF6vsQnc3ZYpEy9ZCk5IT4zlFxW4ASn/L
+QhcrJYy4FzsVNlneQs4h5rbHbl4mH/eKV56llnK3AjLrBytz4k9mWJrrDwe2q1CL
+w48X+gqZwhYlvy1rGqrmPl/rbZtdTUKDLTm4yazbOpFQ37uxdm0Vc/3G5mtxnmc2
+IoN5sda4hFKvllvDYwJOeHBXAgMBAAEwDQYJKoZIhvcNAQELBQADggEBACQo7iJ0
+f3z6bB+zGNHCPX0pQoitgqWxigXQ7FyRIPaC/dVnYF8x9b2IkXC9uLmMiP5TyVSb
+Q8R6Q3Rr3bCxOzNFRnijHO9UaPeFnORRbwavgdsqe3tvqJxn2MvJkUAArtmhn92m
+Qw4oe6ob6YTbdmRCcMnA666EERZoToSefpI27hw7CGPreYQVCJ2vyJrHNNOUS9Eo
+l77RRXXcNWKsHR+3txWHyJjAJDFWje3bBsZGv0ttptWrzGD85Te2U31YlalWx/fu
+w6B292VNU/r/X3YzWgj6hpJaE/oa/PIbjH9Cbbd+t7Twx4O7ooEDLdQqYz/3MS5A
+M1xGvJvBBaVFTsM=
+-----END CERTIFICATE-----
diff --git a/wireless-regdb.spec b/wireless-regdb.spec
index bb648ca..b92fee4 100644
--- a/wireless-regdb.spec
+++ b/wireless-regdb.spec
@@ -16,7 +16,7 @@ BuildArch: noarch
%description
This package contains the wireless regulatory database used by all
cfg80211 based Linux wireless drivers. The wireless database being
-used is maintained by Seth Forshee.
+used is maintained by Chen-Yu Tsai.
http://wireless.kernel.org/en/developers/Regulatory/
%prep