summaryrefslogtreecommitdiffstats
path: root/debian/README.source
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 03:24:09 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 03:24:09 +0000
commit45296c28f7260031283ede25480a094b6e3382d9 (patch)
treeb21c31a14bf20a2e74348174976e81d5c1dbb401 /debian/README.source
parentAdding upstream version 2022.06.06. (diff)
downloadwireless-regdb-45296c28f7260031283ede25480a094b6e3382d9.tar.xz
wireless-regdb-45296c28f7260031283ede25480a094b6e3382d9.zip
Adding debian version 2022.06.06-1.debian/2022.06.06-1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/README.source')
-rw-r--r--debian/README.source31
1 files changed, 31 insertions, 0 deletions
diff --git a/debian/README.source b/debian/README.source
new file mode 100644
index 0000000..14f5435
--- /dev/null
+++ b/debian/README.source
@@ -0,0 +1,31 @@
+If you need to make an NMU, you'll first have to create a key-pair
+and certificate.
+
+1. Set REGDB_AUTHOR to the address you use in the Debian changelog:
+ REGDB_AUTHOR="example@debian.org"
+2. Generate the private key by running:
+ make REGDB_AUTHOR="$REGDB_AUTHOR" ~/".wireless-regdb-$REGDB_AUTHOR.key.priv.pem"
+3. Generate the public key by running:
+ make REGDB_AUTHOR="$REGDB_AUTHOR" "$REGDB_AUTHOR.key.pub.pem"
+4. Generate a certificate by running:
+ openssl req -new -key ~/.wireless-regdb-"$REGDB_AUTHOR.key.priv.pem" \
+ -days 36500 -utf8 -nodes -batch -x509 \
+ -outform PEM -out "$REGDB_AUTHOR.x509.pem" \
+ -config <(cat <<-EOF
+ [ req ]
+ distinguished_name = req_distinguished_name
+ string_mask = utf8only
+ prompt = no
+ [ req_distinguished_name ]
+ commonName = $REGDB_AUTHOR
+ EOF
+ )
+5. Add the certificate to the linux package and regenerate
+ debian/patches/debian/wireless-add-debian-wireless-regdb-certificates.patch
+ as documented in its patch header.
+
+When preparing a source package, you must run 'debian/rules sign' to
+create a detached signature so that the private key is not needed when
+building the binary package.
+
+ -- Ben Hutchings <benh@debian.org>, Sat, 22 Jan 2022 16:50:24 +0100