summaryrefslogtreecommitdiffstats
path: root/doc/README.wslua
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-09-19 04:14:26 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-09-19 04:14:26 +0000
commitc4e8a3222648fcf22ca207f1815ebbf7cd144eeb (patch)
tree93d5c6aa93d9987680dd1adad5685e2ad698f223 /doc/README.wslua
parentAdding upstream version 4.2.6. (diff)
downloadwireshark-upstream.tar.xz
wireshark-upstream.zip
Adding upstream version 4.4.0.upstream/4.4.0upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'doc/README.wslua')
-rw-r--r--doc/README.wslua18
1 files changed, 8 insertions, 10 deletions
diff --git a/doc/README.wslua b/doc/README.wslua
index c26dcf93..63bc1d51 100644
--- a/doc/README.wslua
+++ b/doc/README.wslua
@@ -44,9 +44,8 @@ Lua tables. (you can do so, but it's not advisable)
Both of the scripts above are given the C-source files to search through
by the make process, generated from the lists in epan/wslua/CMakeLists.txt.
Naturally if you add new source files, you need to add them to the list in
-epan/wslua/CMakeLists.txt. You also have to add the module name into
-docbook/user-guide.xml and docbook/wsluarm.xml, and the source files into
-docbook/CMakeLists.txt, to get it to be generated in the user guide.
+epan/wslua/CMakeLists.txt. You also have to add the source files into
+doc/CMakeLists.txt, to get it to be generated in the user guide.
Due to those documentation and registration scripts, you MUST follow some very
specific conventions in the functions you write to expose C-side code to Lua,
@@ -255,10 +254,10 @@ type that make-taps.py has in its Python "types" and "comments" dictionaries.
Note on Lua versions:
-Wireshark supports both Lua 5.1 and 5.2, which are defined as LUA_VERSION_NUM
-values 501 and 502 respectively. When exposing things into Lua, make sure to
+Wireshark supports both Lua 5.3 and 5.4, which are defined as LUA_VERSION_NUM
+values 503 and 504 respectively. When exposing things into Lua, make sure to
use ifdef wrappers for things which changed between the versions of Lua. See
-this for details: http://www.lua.org/manual/5.2/manual.html#8.3
+this for details: http://www.lua.org/manual/5.3/manual.html#8.3
==============================================================================
@@ -284,16 +283,15 @@ file as that WSLUA_MODULE comment. You'll also note the documentation
includes a sub-section for 'Non Method Functions', which it auto-generated
from anything with a 'WSLUA_FUNCTION' macro (as opposed to class member
functions, which use the 'WSLUA_METHOD' and 'WSLUA_CONSTRUCTOR' macros). Also,
-to make new wslua files generate documentation, it is not sufficient to just
-add this macro to a new file and add the file to the CMakeLists.txt; you also
-have to add the module name into docbook/user-guide.xml, and docbook/wsluarm.xml.
+to make new wslua files generate documentation, add this macro to a new file
+and add the file to the doc/CMakeLists.txt.
WSLUA_CONTINUE_MODULE - like WSLUA_MODULE, except used at the top of a .c file
to continue defining classes/functions/etc. within a previously declared module
in a previous file (i.e., one that used WSLUA_MODULE). The module name must match
the original one, and the .c file must be listed after the original one in the
-CMakeLists.txt lists in the docbook directory.
+CMakeLists.txt lists in the doc directory.
WSLUA_ATTRIBUTE - this is another documentation-only "macro", only used within