summaryrefslogtreecommitdiffstats
path: root/epan/dissectors/CMakeListsCustom.txt.example
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-10 20:34:10 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-10 20:34:10 +0000
commite4ba6dbc3f1e76890b22773807ea37fe8fa2b1bc (patch)
tree68cb5ef9081156392f1dd62a00c6ccc1451b93df /epan/dissectors/CMakeListsCustom.txt.example
parentInitial commit. (diff)
downloadwireshark-e4ba6dbc3f1e76890b22773807ea37fe8fa2b1bc.tar.xz
wireshark-e4ba6dbc3f1e76890b22773807ea37fe8fa2b1bc.zip
Adding upstream version 4.2.2.upstream/4.2.2
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'epan/dissectors/CMakeListsCustom.txt.example')
-rw-r--r--epan/dissectors/CMakeListsCustom.txt.example38
1 files changed, 38 insertions, 0 deletions
diff --git a/epan/dissectors/CMakeListsCustom.txt.example b/epan/dissectors/CMakeListsCustom.txt.example
new file mode 100644
index 00000000..3dbf1e61
--- /dev/null
+++ b/epan/dissectors/CMakeListsCustom.txt.example
@@ -0,0 +1,38 @@
+# CMakeListsCustom.txt
+#
+# Wireshark - Network traffic analyzer
+# By Gerald Combs <gerald@wireshark.org>
+# Copyright 1998 Gerald Combs
+#
+# SPDX-License-Identifier: GPL-2.0-or-later
+#
+# You can add custom builtin dissectors here by replacing foo with your dissectors name.
+
+set(CUSTOM_DISSECTOR_SRC
+# ${CMAKE_CURRENT_SOURCE_DIR}/packet-foo.c
+)
+
+set(CUSTOM_DISSECTOR_HEADER_FILES
+# ${CMAKE_CURRENT_SOURCE_DIR}/packet-foo.h
+)
+
+set(CUSTOM_DISSECTOR_SUPPORT_SRC
+# ${CMAKE_CURRENT_SOURCE_DIR}/foo-support.c
+)
+
+set(CUSTOM_DIRTY_ASN1_DISSECTOR_SRC
+# ${CMAKE_CURRENT_SOURCE_DIR}/packet-bar.c
+)
+
+#
+# Editor modelines - https://www.wireshark.org/tools/modelines.html
+#
+# Local variables:
+# c-basic-offset: 8
+# tab-width: 8
+# indent-tabs-mode: t
+# End:
+#
+# vi: set shiftwidth=8 tabstop=8 noexpandtab:
+# :indentSize=8:tabSize=8:noTabs=false:
+#