summaryrefslogtreecommitdiffstats
path: root/packaging
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-17 15:00:59 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-17 15:00:59 +0000
commit982fc7184d46621948e53b485c7504c9d11f3350 (patch)
treeca218a5ad0f5395fd3f39a22754b767c04265711 /packaging
parentReleasing progress-linux version 4.2.4-1~progress7.99u1. (diff)
downloadwireshark-982fc7184d46621948e53b485c7504c9d11f3350.tar.xz
wireshark-982fc7184d46621948e53b485c7504c9d11f3350.zip
Merging upstream version 4.2.5.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'packaging')
-rw-r--r--packaging/debian/changelog2
-rw-r--r--packaging/nsis/mingw64-qt-mapping.txt2
-rw-r--r--packaging/nsis/windeployqt-to-nsis.py6
-rwxr-xr-xpackaging/source/git-export-release.sh.in2
4 files changed, 10 insertions, 2 deletions
diff --git a/packaging/debian/changelog b/packaging/debian/changelog
index 0a5e254..a9d1562 100644
--- a/packaging/debian/changelog
+++ b/packaging/debian/changelog
@@ -1,4 +1,4 @@
-wireshark (4.2.4) unstable; urgency=low
+wireshark (4.2.5) unstable; urgency=low
* Self-made package
diff --git a/packaging/nsis/mingw64-qt-mapping.txt b/packaging/nsis/mingw64-qt-mapping.txt
index 40ca2ef..71e1288 100644
--- a/packaging/nsis/mingw64-qt-mapping.txt
+++ b/packaging/nsis/mingw64-qt-mapping.txt
@@ -24,7 +24,9 @@
"lib/qt6/plugins/multimedia/windowsmediaplugin.dll" "multimedia/windowsmediaplugin.dll"
"lib/qt6/plugins/networkinformation/qnetworklistmanager.dll" "networkinformation/qnetworklistmanager.dll"
"lib/qt6/plugins/platforms/qwindows.dll" "platforms/qwindows.dll"
+# 6.7 renamed QWindowsVistaStylePlugin to QModernWindowsStylePlugin
"lib/qt6/plugins/styles/qwindowsvistastyle.dll" "styles/qwindowsvistastyle.dll"
+"lib/qt6/plugins/styles/qmodernwindowsstyle.dll" "styles/qmodernwindowsstyle.dll"
"lib/qt6/plugins/tls/qcertonlybackend.dll" "tls/qcertonlybackend.dll"
"lib/qt6/plugins/tls/qopensslbackend.dll" "tls/qopensslbackend.dll"
"lib/qt6/plugins/tls/qschannelbackend.dll" "tls/qschannelbackend.dll"
diff --git a/packaging/nsis/windeployqt-to-nsis.py b/packaging/nsis/windeployqt-to-nsis.py
index f3e3e9a..2339cf3 100644
--- a/packaging/nsis/windeployqt-to-nsis.py
+++ b/packaging/nsis/windeployqt-to-nsis.py
@@ -90,6 +90,12 @@ with open(args.outfile, 'w') as f:
path = path.strip('"')
if args.sysroot:
path = os.path.join(args.sysroot, path)
+ if args.mapping and not os.path.isfile(path):
+ # This hack is because Qt 6.7 renamed QWindowsVistaStylePlugin
+ # to QModernWindowsStylePlugin. (This explicit mapping because
+ # windeployqt6 doesn't work well with cross-compiling is
+ # brittle.)
+ continue
file_path = 'File "{}"'.format(path)
print(file_path, file=f)
diff --git a/packaging/source/git-export-release.sh.in b/packaging/source/git-export-release.sh.in
index 51adfb7..a0f876a 100755
--- a/packaging/source/git-export-release.sh.in
+++ b/packaging/source/git-export-release.sh.in
@@ -44,7 +44,7 @@ TARBALL="${DESTDIR}/wireshark-${PROJECT_VERSION}.tar.xz"
# A tarball produced by 'git archive' will have the $Format string
# substituted due to the use of 'export-subst' in .gitattributes.
# shellcheck disable=SC2016
-COMMIT='1fe5bce8d665c0d64e1af63545421c67596db165'
+COMMIT='4aa814ac25a18ea48d4002351ed45d4b245b0c08'
if [[ $COMMIT != \$F* ]] ; then
# This file was extracted from a tarball produced by git archive