summaryrefslogtreecommitdiffstats
path: root/packaging
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-26 17:44:25 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-26 17:44:25 +0000
commitf59ea5f7690c9a01ef6f7f6508084a66c40b1dae (patch)
tree482ee255d71f113be6c62e9ff3543fd6ebb9f12a /packaging
parentReleasing progress-linux version 4.2.2-1.1~progress7.99u1. (diff)
downloadwireshark-f59ea5f7690c9a01ef6f7f6508084a66c40b1dae.tar.xz
wireshark-f59ea5f7690c9a01ef6f7f6508084a66c40b1dae.zip
Merging upstream version 4.2.4.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'packaging')
-rw-r--r--packaging/debian/changelog2
-rw-r--r--packaging/debian/libwireshark17.symbols2
-rwxr-xr-xpackaging/macosx/ChmodBPF/install-scripts/postinstall5
-rw-r--r--packaging/nsis/CMakeLists.txt2
-rw-r--r--packaging/nsis/GetWindowsVersion.nsh190
-rw-r--r--packaging/nsis/logray.nsi29
-rw-r--r--packaging/nsis/windeployqt-to-nsis.py4
-rw-r--r--packaging/nsis/wireshark.nsi67
-rwxr-xr-xpackaging/source/git-export-release.sh.in2
-rw-r--r--packaging/wix/Prerequisites.wxi10
10 files changed, 61 insertions, 252 deletions
diff --git a/packaging/debian/changelog b/packaging/debian/changelog
index 3240f8b..0a5e254 100644
--- a/packaging/debian/changelog
+++ b/packaging/debian/changelog
@@ -1,4 +1,4 @@
-wireshark (4.2.2) unstable; urgency=low
+wireshark (4.2.4) unstable; urgency=low
* Self-made package
diff --git a/packaging/debian/libwireshark17.symbols b/packaging/debian/libwireshark17.symbols
index 035399c..7f21fc1 100644
--- a/packaging/debian/libwireshark17.symbols
+++ b/packaging/debian/libwireshark17.symbols
@@ -278,6 +278,7 @@ libwireshark.so.17 libwireshark17 #MINVER#
decode_zcl_time_in_100ms@Base 2.5.2
decode_zcl_time_in_minutes@Base 2.5.2
decode_zcl_time_in_seconds@Base 2.5.2
+ decrement_dissection_depth@Base 4.2.4
delete_itu_tcap_subdissector@Base 1.9.1
deregister_depend_dissector@Base 2.1.0
destroy_print_stream@Base 1.12.0~rc1
@@ -997,6 +998,7 @@ libwireshark.so.17 libwireshark17 #MINVER#
ieee802a_add_oui@Base 1.9.1
in_cksum@Base 1.9.1
in_cksum_ret_partial@Base 4.2.0
+ increment_dissection_depth@Base 4.2.4
init_srt_table@Base 1.99.8
init_srt_table_row@Base 1.99.8
ip_checksum@Base 1.99.0
diff --git a/packaging/macosx/ChmodBPF/install-scripts/postinstall b/packaging/macosx/ChmodBPF/install-scripts/postinstall
index 1f11eb3..8f5035d 100755
--- a/packaging/macosx/ChmodBPF/install-scripts/postinstall
+++ b/packaging/macosx/ChmodBPF/install-scripts/postinstall
@@ -32,4 +32,9 @@ chown root:wheel "$CHMOD_BPF_PLIST"
# Clean up our legacy startup item if it's still around.
rm -rf /Library/StartupItems/ChmodBPF
+# Try to bootout first, otherwise bootstrap will fail with
+# "Bootstrap failed: 5: Input/output error"
+# if org.wireshark.ChmodBPF is already loaded.
+launchctl bootout system "$CHMOD_BPF_PLIST" > /dev/null 2>&1
+
launchctl bootstrap system "$CHMOD_BPF_PLIST"
diff --git a/packaging/nsis/CMakeLists.txt b/packaging/nsis/CMakeLists.txt
index d0c4866..5f9043d 100644
--- a/packaging/nsis/CMakeLists.txt
+++ b/packaging/nsis/CMakeLists.txt
@@ -22,7 +22,6 @@ set(WIRESHARK_NSIS_GENERATED_FILES ${WIRESHARK_NSIS_GENERATED_FILES} PARENT_SCOP
set(WIRESHARK_NSIS_FILES
${CMAKE_CURRENT_SOURCE_DIR}/wireshark.nsi
${CMAKE_CURRENT_SOURCE_DIR}/wireshark-common.nsh
- ${CMAKE_CURRENT_SOURCE_DIR}/GetWindowsVersion.nsh
${CMAKE_CURRENT_SOURCE_DIR}/servicelib.nsh
${CMAKE_CURRENT_SOURCE_DIR}/NpcapPage.ini
${CMAKE_CURRENT_SOURCE_DIR}/USBPcapPage.ini
@@ -41,7 +40,6 @@ set(LOGRAY_NSIS_FILES
logray.nsi
uninstall-logray.nsi
logray-common.nsh
- GetWindowsVersion.nsh
servicelib.nsh
NpcapPage.ini
USBPcapPage.ini
diff --git a/packaging/nsis/GetWindowsVersion.nsh b/packaging/nsis/GetWindowsVersion.nsh
deleted file mode 100644
index d020129..0000000
--- a/packaging/nsis/GetWindowsVersion.nsh
+++ /dev/null
@@ -1,190 +0,0 @@
-; GetWindowsVersion 4.1.1 (2015-06-22) - alternate script with server versions
-;
-; https://nsis.sourceforge.io/Get_Windows_version
-;
-; Based on Yazno's function, http://yazno.tripod.com/powerpimpit/
-; Update by Joost Verburg
-; Update (Macro, Define, Windows 7 detection) - John T. Haller of PortableApps.com - 2008-01-07
-; Update (Windows 8 detection) - Marek Mizanin (Zanir) - 2013-02-07
-; Update (Windows 8.1 detection) - John T. Haller of PortableApps.com - 2014-04-04
-; Update (Windows 2008, 2008R2, 2012 and 2012R2 detection) - Francisco SimoƵes Filho franksimoes@gmail.com - 2014-08-25
-; Update (Windows 10 TP detection) - John T. Haller of PortableApps.com - 2014-10-01
-; Update (Windows 10 TP4 and 2016 detection, and added include guards) - Kairu - 2015-06-22
-;
-; Usage: ${GetWindowsVersion} $R0
-;
-; $R0 contains: 95, 98, ME, NT x.x, 2000, XP, 2003, Vista, 2008, 7, 2008R2,
-; 8, 2012, 8.1, 2012R2, 10.0, 2016 or '' (for unknown)
-
-!ifndef __GET_WINDOWS_VERSION_NSH
-!define __GET_WINDOWS_VERSION_NSH
-
-Function GetWindowsVersion
-
- Push $R0
- Push $R1
- Push $R2
-
- ClearErrors
-
- ; check if Windows NT family
- ReadRegStr $R0 HKLM \
- "SOFTWARE\Microsoft\Windows NT\CurrentVersion" CurrentVersion
-
- IfErrors 0 lbl_winnt
-
- ; we are not NT
- ReadRegStr $R0 HKLM \
- "SOFTWARE\Microsoft\Windows\CurrentVersion" VersionNumber
-
- StrCpy $R1 $R0 1
- StrCmp $R1 '4' 0 lbl_error
-
- StrCpy $R1 $R0 3
-
- StrCmp $R1 '4.0' lbl_win32_95
- StrCmp $R1 '4.9' lbl_win32_ME lbl_win32_98
-
- lbl_win32_95:
- StrCpy $R0 '95'
- Goto lbl_done
-
- lbl_win32_98:
- StrCpy $R0 '98'
- Goto lbl_done
-
- lbl_win32_ME:
- StrCpy $R0 'ME'
- Goto lbl_done
-
- lbl_winnt:
-
- ; check if Windows is Client or Server.
- ReadRegStr $R2 HKLM \
- "SOFTWARE\Microsoft\Windows NT\CurrentVersion" InstallationType
-
- StrCpy $R1 $R0 1
-
- StrCmp $R1 '3' lbl_winnt_x
- StrCmp $R1 '4' lbl_winnt_x
-
- StrCpy $R1 $R0 3
-
- StrCmp $R1 '5.0' lbl_winnt_2000
- StrCmp $R1 '5.1' lbl_winnt_XP
- StrCmp $R1 '5.2' lbl_winnt_2003
- StrCmp $R1 '6.0' lbl_winnt_vista_2008
- StrCmp $R1 '6.1' lbl_winnt_7_2008R2
- StrCmp $R1 '6.2' lbl_winnt_8_2012
- StrCmp $R1 '6.3' lbl_winnt_81_2012R2
- StrCmp $R1 '6.4' lbl_winnt_10_2016 ; the early Windows 10 tech previews used version 6.4
-
- StrCpy $R1 $R0 4
-
- StrCmp $R1 '10.0' lbl_winnt_10_2016
- Goto lbl_error
-
- lbl_winnt_x:
- StrCpy $R0 "NT $R0" 6
- Goto lbl_done
-
- lbl_winnt_2000:
- Strcpy $R0 '2000'
- Goto lbl_done
-
- lbl_winnt_XP:
- Strcpy $R0 'XP'
- Goto lbl_done
-
- lbl_winnt_2003:
- Strcpy $R0 '2003'
- Goto lbl_done
-
- ;----------------- Family - Vista / 2008 -------------
- lbl_winnt_vista_2008:
- StrCmp $R2 'Client' go_vista
- StrCmp $R2 'Server' go_2008
-
- go_vista:
- Strcpy $R0 'Vista'
- Goto lbl_done
-
- go_2008:
- Strcpy $R0 '2008'
- Goto lbl_done
- ;-----------------------------------------------------
-
- ;----------------- Family - 7 / 2008R2 -------------
- lbl_winnt_7_2008R2:
- StrCmp $R2 'Client' go_7
- StrCmp $R2 'Server' go_2008R2
-
- go_7:
- Strcpy $R0 '7'
- Goto lbl_done
-
- go_2008R2:
- Strcpy $R0 '2008R2'
- Goto lbl_done
- ;-----------------------------------------------------
-
- ;----------------- Family - 8 / 2012 -------------
- lbl_winnt_8_2012:
- StrCmp $R2 'Client' go_8
- StrCmp $R2 'Server' go_2012
-
- go_8:
- Strcpy $R0 '8'
- Goto lbl_done
-
- go_2012:
- Strcpy $R0 '2012'
- Goto lbl_done
- ;-----------------------------------------------------
-
- ;----------------- Family - 8.1 / 2012R2 -------------
- lbl_winnt_81_2012R2:
- StrCmp $R2 'Client' go_81
- StrCmp $R2 'Server' go_2012R2
-
- go_81:
- Strcpy $R0 '8.1'
- Goto lbl_done
-
- go_2012R2:
- Strcpy $R0 '2012R2'
- Goto lbl_done
- ;-----------------------------------------------------
-
- ;----------------- Family - 10 / 2016 -------------
- lbl_winnt_10_2016:
- StrCmp $R2 'Client' go_10
- StrCmp $R2 'Server' go_2016
-
- go_10:
- Strcpy $R0 '10.0'
- Goto lbl_done
-
- go_2016:
- Strcpy $R0 '2016'
- Goto lbl_done
- ;-----------------------------------------------------
-
- lbl_error:
- Strcpy $R0 ''
- lbl_done:
-
- Pop $R2
- Pop $R1
- Exch $R0
-
-FunctionEnd
-
-!macro GetWindowsVersion OUTPUT_VALUE
- Call GetWindowsVersion
- Pop `${OUTPUT_VALUE}`
-!macroend
-
-!define GetWindowsVersion '!insertmacro "GetWindowsVersion"'
-
-!endif
diff --git a/packaging/nsis/logray.nsi b/packaging/nsis/logray.nsi
index e87e3ca..5aed3b2 100644
--- a/packaging/nsis/logray.nsi
+++ b/packaging/nsis/logray.nsi
@@ -250,11 +250,11 @@ Var WIX_DISPLAYVERSION
Var WIX_UNINSTALLSTRING
; ============================================================================
-; 64-bit support
+; Platform and OS version checks
; ============================================================================
-!include x64.nsh
-!include "GetWindowsVersion.nsh"
+!include x64.nsh
+!include WinVer.nsh
!include WinMessages.nsh
Function .onInit
@@ -266,9 +266,6 @@ Function .onInit
${EndIf}
!endif
- ; Get the Windows version
- ${GetWindowsVersion} $R0
-
; This should match the following:
; - The NTDDI_VERSION and _WIN32_WINNT parts of cmakeconfig.h.in
; - The <compatibility><application> section in image\wireshark.exe.manifest.in
@@ -277,23 +274,13 @@ Function .onInit
; Uncomment to test.
; MessageBox MB_OK "You're running Windows $R0."
- ; Check if we're able to run with this version
- StrCmp $R0 '95' lbl_winversion_unsupported
- StrCmp $R0 '98' lbl_winversion_unsupported
- StrCmp $R0 'ME' lbl_winversion_unsupported
- StrCmp $R0 'NT 4.0' lbl_winversion_unsupported
- StrCmp $R0 '2000' lbl_winversion_unsupported
- StrCmp $R0 'XP' lbl_winversion_unsupported
- StrCmp $R0 '2003' lbl_winversion_unsupported
- StrCmp $R0 'Vista' lbl_winversion_unsupported
- StrCmp $R0 '2008' lbl_winversion_unsupported
- Goto lbl_winversion_supported
-
-lbl_winversion_unsupported:
+
+${If} ${AtMostWin8.1}
+${OrIf} ${AtMostWin2012R2}
MessageBox MB_OK \
- "Windows $R0 is not supported." \
- /SD IDOK
+ "Windows 10, Server 2016, and later are required." /SD IDOK
Quit
+${EndIf}
lbl_winversion_supported:
!insertmacro IsLograyRunning
diff --git a/packaging/nsis/windeployqt-to-nsis.py b/packaging/nsis/windeployqt-to-nsis.py
index 2881f31..f3e3e9a 100644
--- a/packaging/nsis/windeployqt-to-nsis.py
+++ b/packaging/nsis/windeployqt-to-nsis.py
@@ -74,6 +74,10 @@ with open(args.outfile, 'w') as f:
line = line.strip()
if not line or line.startswith('#'):
continue
+ if line.startswith('Adding in plugin'):
+ # https://bugreports.qt.io/browse/QTBUG-122257
+ # Affects 6.6.0 - 6.6.2
+ continue
path, relative = line.split(" ")
rel_path = os.path.split(relative)
if len(rel_path) > 1:
diff --git a/packaging/nsis/wireshark.nsi b/packaging/nsis/wireshark.nsi
index 5271cd3..0f2d55d 100644
--- a/packaging/nsis/wireshark.nsi
+++ b/packaging/nsis/wireshark.nsi
@@ -282,11 +282,11 @@ Var WIX_DISPLAYVERSION
Var WIX_UNINSTALLSTRING
; ============================================================================
-; 64-bit support
+; Platform and OS version checks
; ============================================================================
-!include x64.nsh
-!include "GetWindowsVersion.nsh"
+!include x64.nsh
+!include WinVer.nsh
!include WinMessages.nsh
Function .onInit
@@ -309,9 +309,6 @@ Function .onInit
${EndIf}
!endif
- ; Get the Windows version
- ${GetWindowsVersion} $R0
-
; This should match the following:
; - The NTDDI_VERSION and _WIN32_WINNT parts of cmakeconfig.h.in
; - The <compatibility><application> section in image\wireshark.exe.manifest.in
@@ -320,49 +317,51 @@ Function .onInit
; Uncomment to test.
; MessageBox MB_OK "You're running Windows $R0."
- ; Check if we're able to run with this version
- StrCmp $R0 '95' lbl_winversion_unsupported
- StrCmp $R0 '98' lbl_winversion_unsupported
- StrCmp $R0 'ME' lbl_winversion_unsupported
- StrCmp $R0 'NT 4.0' lbl_winversion_unsupported_nt4
- StrCmp $R0 '2000' lbl_winversion_unsupported_2000
- StrCmp $R0 'XP' lbl_winversion_unsupported_xp_2003
- StrCmp $R0 '2003' lbl_winversion_unsupported_xp_2003
- StrCmp $R0 'Vista' lbl_winversion_unsupported_vista_2008
- StrCmp $R0 '2008' lbl_winversion_unsupported_vista_2008
- Goto lbl_winversion_supported
-
-lbl_winversion_unsupported:
+${If} ${AtMostWinME}
+ MessageBox MB_OK \
+ "Windows 95, 98, and ME are no longer supported.$\nPlease install Ethereal 0.99.0 instead." \
+ /SD IDOK
+ Quit
+${EndIf}
+
+${If} ${IsWinNT4}
MessageBox MB_OK \
- "Windows $R0 is no longer supported.$\nPlease install Ethereal 0.99.0 instead." \
- /SD IDOK
+ "Windows NT 4.0 is no longer supported.$\nPlease install Wireshark 0.99.4 instead." \
+ /SD IDOK
Quit
+${EndIf}
-lbl_winversion_unsupported_nt4:
+${If} ${IsWin2000}
MessageBox MB_OK \
- "Windows $R0 is no longer supported.$\nPlease install Wireshark 0.99.4 instead." \
- /SD IDOK
+ "Windows 2000 is no longer supported.$\nPlease install Wireshark 1.2 or 1.0 instead." \
+ /SD IDOK
Quit
+${EndIf}
-lbl_winversion_unsupported_2000:
+${If} ${IsWinXP}
+${OrIf} ${IsWin2003}
MessageBox MB_OK \
- "Windows $R0 is no longer supported.$\nPlease install Wireshark 1.2 or 1.0 instead." \
- /SD IDOK
+ "Windows XP and Server 2003 are no longer supported.$\nPlease install ${PROGRAM_NAME} 1.12 or 1.10 instead." \
+ /SD IDOK
Quit
+${EndIf}
-lbl_winversion_unsupported_xp_2003:
+${If} ${IsWinVista}
+${OrIf} ${IsWin2008}
MessageBox MB_OK \
- "Windows $R0 is no longer supported.$\nPlease install ${PROGRAM_NAME} 1.12 or 1.10 instead." \
- /SD IDOK
+ "Windows Vista and Server 2008 are no longer supported.$\nPlease install ${PROGRAM_NAME} 2.2 instead." \
+ /SD IDOK
Quit
+${EndIf}
-lbl_winversion_unsupported_vista_2008:
+${If} ${AtMostWin8.1}
+${OrIf} ${AtMostWin2012R2}
MessageBox MB_OK \
- "Windows $R0 is no longer supported.$\nPlease install ${PROGRAM_NAME} 2.2 instead." \
- /SD IDOK
+ "Windows 7, 8, 8.1, Server 2008R2, and Server 2012 are no longer supported.$\nPlease install ${PROGRAM_NAME} 4.0 instead." \
+ /SD IDOK
Quit
+${EndIf}
-lbl_winversion_supported:
!insertmacro IsWiresharkRunning
; Default control values.
diff --git a/packaging/source/git-export-release.sh.in b/packaging/source/git-export-release.sh.in
index 854af25..51adfb7 100755
--- a/packaging/source/git-export-release.sh.in
+++ b/packaging/source/git-export-release.sh.in
@@ -44,7 +44,7 @@ TARBALL="${DESTDIR}/wireshark-${PROJECT_VERSION}.tar.xz"
# A tarball produced by 'git archive' will have the $Format string
# substituted due to the use of 'export-subst' in .gitattributes.
# shellcheck disable=SC2016
-COMMIT='40459284278611128aac5cef35a563218933f8da'
+COMMIT='1fe5bce8d665c0d64e1af63545421c67596db165'
if [[ $COMMIT != \$F* ]] ; then
# This file was extracted from a tarball produced by git archive
diff --git a/packaging/wix/Prerequisites.wxi b/packaging/wix/Prerequisites.wxi
index 54e8416..aa03a45 100644
--- a/packaging/wix/Prerequisites.wxi
+++ b/packaging/wix/Prerequisites.wxi
@@ -17,7 +17,7 @@
<!-- This should match the following:
- The NTDDI_VERSION and _WIN32_WINNT parts of cmakeconfig.h.in
- The <compatibility><application> section in image\wireshark.exe.manifest.in
- - The GetWindowsVersion parts of packaging\nsis\wireshark.nsi
+ - The WinVer parts of packaging\nsis\wireshark.nsi
-->
<Condition Message="Windows 2000 is no longer supported. Please install $(var.WiresharkName) 1.2 or 1.0 instead.">
<![CDATA[Installed OR (VersionNT < 500) OR (VersionNT > 500)]]>
@@ -35,8 +35,12 @@
<![CDATA[Installed OR (VersionNT < 600) OR (VersionNT > 600)]]>
</Condition>
- <Condition Message="$(var.WiresharkName)$(var.WiresharkVersion) is only supported on Windows 7, Windows Server 2008R2, or higher.">
- <![CDATA[Installed OR (VersionNT >= 601)]]>
+ <Condition Message="Windows 7, 8, 8.1, Server 2008R2, and Server 2012 are no longer supported. Please install $(var.WiresharkName) 4.0 instead.">
+ <![CDATA[Installed OR (VersionNT < 601) OR (VersionNT > 602)]]>
+ </Condition>
+
+ <Condition Message="$(var.WiresharkName)$(var.WiresharkVersion) is only supported on Windows 10, Windows Server 2016, or higher.">
+ <![CDATA[Installed OR (VersionNT >= 603)]]>
</Condition>
<!--