summaryrefslogtreecommitdiffstats
path: root/tools/macos-setup-patches
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-09-19 04:14:53 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-09-19 04:14:53 +0000
commita86c5f7cae7ec9a3398300555a0b644689d946a1 (patch)
tree39fe4b107c71174fd1e8a8ceb9a4d2aa14116248 /tools/macos-setup-patches
parentReleasing progress-linux version 4.2.6-1~progress7.99u1. (diff)
downloadwireshark-a86c5f7cae7ec9a3398300555a0b644689d946a1.tar.xz
wireshark-a86c5f7cae7ec9a3398300555a0b644689d946a1.zip
Merging upstream version 4.4.0.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tools/macos-setup-patches')
-rw-r--r--tools/macos-setup-patches/falco-include-dirs.patch15
-rw-r--r--tools/macos-setup-patches/falco-uthash_h-install.patch9
-rw-r--r--tools/macos-setup-patches/glib-pkgconfig.patch10
-rw-r--r--tools/macos-setup-patches/gnutls-pkgconfig.patch8
-rwxr-xr-xtools/macos-setup-patches/qt-fix-pc-file24
-rwxr-xr-xtools/macos-setup-patches/qt-fix-pc-files21
-rw-r--r--tools/macos-setup-patches/snappy-signed.patch11
-rw-r--r--tools/macos-setup-patches/spandsp-configure-patch53
8 files changed, 151 insertions, 0 deletions
diff --git a/tools/macos-setup-patches/falco-include-dirs.patch b/tools/macos-setup-patches/falco-include-dirs.patch
new file mode 100644
index 00000000..68f5f228
--- /dev/null
+++ b/tools/macos-setup-patches/falco-include-dirs.patch
@@ -0,0 +1,15 @@
+758865ee6 update(cmake): Don't add build directories to our pc files
+diff --git a/userspace/libsinsp/CMakeLists.txt b/userspace/libsinsp/CMakeLists.txt
+index 6104603e8..1989ea3fb 100644
+--- a/userspace/libsinsp/CMakeLists.txt
++++ b/userspace/libsinsp/CMakeLists.txt
+@@ -335,6 +335,9 @@ endforeach()
+ # Build our pkg-config "Cflags:" flags.
+ set(SINSP_PKG_CONFIG_INCLUDES "")
+ foreach(sinsp_include_directory ${LIBSINSP_INCLUDE_DIRS})
++ if (${sinsp_include_directory} MATCHES "^${CMAKE_SOURCE_DIR}" OR ${sinsp_include_directory} MATCHES "^${CMAKE_BINARY_DIR}")
++ continue()
++ endif()
+ list(APPEND SINSP_PKG_CONFIG_INCLUDES -I${sinsp_include_directory})
+ endforeach()
+
diff --git a/tools/macos-setup-patches/falco-uthash_h-install.patch b/tools/macos-setup-patches/falco-uthash_h-install.patch
new file mode 100644
index 00000000..7e1f7855
--- /dev/null
+++ b/tools/macos-setup-patches/falco-uthash_h-install.patch
@@ -0,0 +1,9 @@
+--- falco-libs-0.14.1/cmake/modules/libscap.cmake.orig 2024-03-25 22:46:40
++++ falco-libs-0.14.1/cmake/modules/libscap.cmake 2024-03-25 22:46:10
+@@ -139,5 +139,6 @@
+ FILES_MATCHING PATTERN "*.h")
+ install(FILES ${PROJECT_BINARY_DIR}/libscap/scap_config.h DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/${LIBS_PACKAGE_NAME}/libscap)
+ install(FILES ${PROJECT_BINARY_DIR}/libscap/scap_strl_config.h DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/${LIBS_PACKAGE_NAME}/libscap)
++install(FILES ${PROJECT_BINARY_DIR}/uthash-prefix/src/uthash/src/uthash.h DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/${LIBS_PACKAGE_NAME}/libscap)
+ install(FILES ${PROJECT_BINARY_DIR}/libscap/libscap.pc DESTINATION ${CMAKE_INSTALL_LIBDIR}/pkgconfig)
+ endif()
diff --git a/tools/macos-setup-patches/glib-pkgconfig.patch b/tools/macos-setup-patches/glib-pkgconfig.patch
new file mode 100644
index 00000000..07761460
--- /dev/null
+++ b/tools/macos-setup-patches/glib-pkgconfig.patch
@@ -0,0 +1,10 @@
+--- gobject-2.0.pc.in.orig 2011-12-30 22:08:27.000000000 +0100
++++ gobject-2.0.pc.in 2011-12-30 22:09:06.000000000 +0100
+@@ -7,6 +7,6 @@
+ Description: GLib Type, Object, Parameter and Signal Library
+ Requires: glib-2.0
+ Version: @VERSION@
+-Libs: -L${libdir} -lgobject-2.0
++Libs: -L${libdir} -lgobject-2.0 -lffi
+ Libs.private: @LIBFFI_LIBS@
+ Cflags:
diff --git a/tools/macos-setup-patches/gnutls-pkgconfig.patch b/tools/macos-setup-patches/gnutls-pkgconfig.patch
new file mode 100644
index 00000000..f0ad93ec
--- /dev/null
+++ b/tools/macos-setup-patches/gnutls-pkgconfig.patch
@@ -0,0 +1,8 @@
+--- gnutls.pc.in.orig 2012-05-27 02:08:48.000000000 +0200
++++ gnutls.pc.in 2012-05-27 02:11:39.000000000 +0200
+@@ -21,5 +21,4 @@
+ Version: @VERSION@
+ Libs: -L${libdir} -lgnutls
+ Libs.private: @LTLIBGCRYPT@ @LTLIBNETTLE@ @NETTLE_LIBS@ @GNUTLS_ZLIB_LIBS_PRIVATE@
+-@GNUTLS_REQUIRES_PRIVATE@
+ Cflags: -I${includedir}
diff --git a/tools/macos-setup-patches/qt-fix-pc-file b/tools/macos-setup-patches/qt-fix-pc-file
new file mode 100755
index 00000000..fa9ba54b
--- /dev/null
+++ b/tools/macos-setup-patches/qt-fix-pc-file
@@ -0,0 +1,24 @@
+#! /bin/sh
+#
+# Fix a Qt .pc file's flags.
+#
+# Wireshark - Network traffic analyzer
+# By Gerald Combs <gerald@wireshark.org>
+# Copyright 2014 Gerald Combs
+#
+# SPDX-License-Identifier: GPL-2.0-or-later
+#
+# Fix a single Qt .pc file to provide the right flags; a -F flag is
+# needed to point to the directory under which the frameworks are
+# placed, and a -I flag needs to point to the directory where
+# the include files for the component in question are place in
+# the framework's directory hierarchy, rather thany to where the
+# include files *would* be if the component *weren't* distributed
+# as a framework.
+#
+ed - "$1" <<EOF
+H
+/^Cflags: /s;-I\${includedir}/\([A-Za-z0-9]*\);-I\${libdir}/\1.framework/Versions/5/Headers;
+/^Cflags: /s;;Cflags: -F\${libdir} ;
+w
+q
diff --git a/tools/macos-setup-patches/qt-fix-pc-files b/tools/macos-setup-patches/qt-fix-pc-files
new file mode 100755
index 00000000..d30edb07
--- /dev/null
+++ b/tools/macos-setup-patches/qt-fix-pc-files
@@ -0,0 +1,21 @@
+#! /bin/sh
+#
+# Fix the .pc files for versions of Qt installed from binary packages.
+#
+# Wireshark - Network traffic analyzer
+# By Gerald Combs <gerald@wireshark.org>
+# Copyright 2014 Gerald Combs
+#
+# SPDX-License-Identifier: GPL-2.0-or-later
+#
+# See bug QTBUG-35256 for the full painful story. Shorter version:
+# the macOS Qt packages provide the Qt components as frameworks, but
+# the .pc files don't generate the right CFLAGS/CXXFLAGS to make
+# that work, so autoconf doesn't work correctly.
+#
+if [ "$#" != 1 ]
+then
+ echo "Usage: qt-fix-pc-files <top-level Qt directory>" 1>&1
+ exit 1
+fi
+find "$1" -name "*.pc" -exec tools/macos-setup-patches/qt-fix-pc-file {} ";"
diff --git a/tools/macos-setup-patches/snappy-signed.patch b/tools/macos-setup-patches/snappy-signed.patch
new file mode 100644
index 00000000..0018fcc4
--- /dev/null
+++ b/tools/macos-setup-patches/snappy-signed.patch
@@ -0,0 +1,11 @@
+--- snappy.cc.orig 2023-09-14 01:04:05
++++ snappy.cc 2023-09-14 01:04:28
+@@ -1290,7 +1290,7 @@
+ DeferMemCopy(&deferred_src, &deferred_length, from, len);
+ }
+ } while (ip < ip_limit_min_slop &&
+- (op + deferred_length) < op_limit_min_slop);
++ static_cast<ptrdiff_t>(op + deferred_length) < op_limit_min_slop);
+ exit:
+ ip--;
+ assert(ip <= ip_limit);
diff --git a/tools/macos-setup-patches/spandsp-configure-patch b/tools/macos-setup-patches/spandsp-configure-patch
new file mode 100644
index 00000000..5a898f99
--- /dev/null
+++ b/tools/macos-setup-patches/spandsp-configure-patch
@@ -0,0 +1,53 @@
+*** configure.dist 2014-06-04 07:28:14.000000000 -0700
+--- configure 2017-08-07 00:16:39.000000000 -0700
+***************
+*** 19658,19664 ****
+
+ case "${ax_cv_c_compiler_vendor}" in
+ gnu)
+! COMP_VENDOR_CFLAGS="-std=gnu99 -ffast-math -Wall -Wunused-variable -Wunused-but-set-variable -Wwrite-strings -Wstrict-prototypes -Wmissing-prototypes $COMP_VENDOR_CFLAGS"
+ if test "$enable_avx" = "yes" ; then
+ COMP_VENDOR_CFLAGS="-mavx $COMP_VENDOR_CFLAGS"
+ fi
+--- 19658,19664 ----
+
+ case "${ax_cv_c_compiler_vendor}" in
+ gnu)
+! COMP_VENDOR_CFLAGS="-std=gnu99 -ffast-math -Wall -Wunused-variable -Wwrite-strings -Wstrict-prototypes -Wmissing-prototypes $COMP_VENDOR_CFLAGS"
+ if test "$enable_avx" = "yes" ; then
+ COMP_VENDOR_CFLAGS="-mavx $COMP_VENDOR_CFLAGS"
+ fi
+***************
+*** 19733,19739 ****
+
+ ;;
+ intel)
+! COMP_VENDOR_CFLAGS="-std=c99 -D_POSIX_C_SOURCE=2 -D_GNU_SOURCE=1 -Wall -Wunused-variable -Wunused-but-set-variable -Wwrite-strings -Wstrict-prototypes -Wmissing-prototypes $COMP_VENDOR_CFLAGS"
+ if test "$enable_avx" = "yes" ; then
+ COMP_VENDOR_CFLAGS="-mavx $COMP_VENDOR_CFLAGS"
+ fi
+--- 19733,19739 ----
+
+ ;;
+ intel)
+! COMP_VENDOR_CFLAGS="-std=c99 -D_POSIX_C_SOURCE=2 -D_GNU_SOURCE=1 -Wall -Wunused-variable -Wwrite-strings -Wstrict-prototypes -Wmissing-prototypes $COMP_VENDOR_CFLAGS"
+ if test "$enable_avx" = "yes" ; then
+ COMP_VENDOR_CFLAGS="-mavx $COMP_VENDOR_CFLAGS"
+ fi
+***************
+*** 19767,19773 ****
+ COMP_VENDOR_LDFLAGS=
+ ;;
+ *)
+! COMP_VENDOR_CFLAGS="-std=c99 -Wall -Wunused-variable -Wunused-but-set-variable -Wwrite-strings -Wstrict-prototypes -Wmissing-prototypes $COMP_VENDOR_CFLAGS"
+ COMP_VENDOR_LDFLAGS=
+ ;;
+ esac
+--- 19767,19773 ----
+ COMP_VENDOR_LDFLAGS=
+ ;;
+ *)
+! COMP_VENDOR_CFLAGS="-std=c99 -Wall -Wunused-variable -Wwrite-strings -Wstrict-prototypes -Wmissing-prototypes $COMP_VENDOR_CFLAGS"
+ COMP_VENDOR_LDFLAGS=
+ ;;
+ esac