summaryrefslogtreecommitdiffstats
path: root/cmake/modules/UseCustomIncludes.cmake
diff options
context:
space:
mode:
Diffstat (limited to 'cmake/modules/UseCustomIncludes.cmake')
-rw-r--r--cmake/modules/UseCustomIncludes.cmake18
1 files changed, 18 insertions, 0 deletions
diff --git a/cmake/modules/UseCustomIncludes.cmake b/cmake/modules/UseCustomIncludes.cmake
new file mode 100644
index 0000000..be01303
--- /dev/null
+++ b/cmake/modules/UseCustomIncludes.cmake
@@ -0,0 +1,18 @@
+#
+# - Include a custom CMake file relative to the current source directory.
+# - If no filename is provided, CMakeListsCustom.txt is used.
+#
+macro( ADD_CUSTOM_CMAKE_INCLUDE )
+ if( ${ARGN} )
+ set( _file_list ${ARGN} )
+ else()
+ set( _file_list CMakeListsCustom.txt )
+ endif()
+ foreach (_include ${_file_list})
+ set( _include_file ${CMAKE_CURRENT_SOURCE_DIR}/${_include} )
+ if( EXISTS ${_include_file} )
+ message ( STATUS "Custom file found, including: ${_include_file}" )
+ include( ${_include_file} )
+ endif()
+ endforeach()
+endmacro()