summaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 03:10:08 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-19 03:10:08 +0000
commit5262a872f308b3b584c97d621992fb3877e392b8 (patch)
treeb956c322376141abeafe639bd72cfecdf16954b5 /src/Makefile.am
parentInitial commit. (diff)
downloadxz-utils-5262a872f308b3b584c97d621992fb3877e392b8.tar.xz
xz-utils-5262a872f308b3b584c97d621992fb3877e392b8.zip
Adding upstream version 5.6.1+really5.4.5.upstream/5.6.1+really5.4.5
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am42
1 files changed, 42 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..d199e85
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,42 @@
+##
+## Author: Lasse Collin
+##
+## This file has been put into the public domain.
+## You can do whatever you want with this file.
+##
+
+SUBDIRS = liblzma xzdec
+
+if COND_XZ
+SUBDIRS += xz
+endif
+
+if COND_LZMAINFO
+SUBDIRS += lzmainfo
+endif
+
+if COND_SCRIPTS
+SUBDIRS += scripts
+endif
+
+EXTRA_DIST = \
+ common/common_w32res.rc \
+ common/mythread.h \
+ common/sysdefs.h \
+ common/tuklib_common.h \
+ common/tuklib_config.h \
+ common/tuklib_cpucores.c \
+ common/tuklib_cpucores.h \
+ common/tuklib_exit.c \
+ common/tuklib_exit.h \
+ common/tuklib_gettext.h \
+ common/tuklib_integer.h \
+ common/tuklib_mbstr_fw.c \
+ common/tuklib_mbstr.h \
+ common/tuklib_mbstr_width.c \
+ common/tuklib_open_stdxxx.c \
+ common/tuklib_open_stdxxx.h \
+ common/tuklib_physmem.c \
+ common/tuklib_physmem.h \
+ common/tuklib_progname.c \
+ common/tuklib_progname.h