summaryrefslogtreecommitdiffstats
path: root/debian/autogen.sh
diff options
context:
space:
mode:
Diffstat (limited to 'debian/autogen.sh')
-rwxr-xr-xdebian/autogen.sh32
1 files changed, 32 insertions, 0 deletions
diff --git a/debian/autogen.sh b/debian/autogen.sh
new file mode 100755
index 0000000..05a3a9f
--- /dev/null
+++ b/debian/autogen.sh
@@ -0,0 +1,32 @@
+#!/bin/sh
+# Generate debian/changelog.upstream, debian/generated-m4.list,
+# and debian/generated-po.list.
+#
+# Uses debian/changelog, the git revision log, and .gitignore
+# files from the current checkout.
+
+set -e
+
+changelog_needs_update() {
+ test -e debian/changelog.upstream &&
+ read line < debian/changelog.upstream ||
+ return 0
+
+ ver=${line#Version } &&
+ ver=${ver%;*} &&
+ test "$ver" != "" ||
+ return 0
+
+ read line < debian/changelog &&
+ rhs=${line#*(} &&
+ deb_ver=${rhs%)*} &&
+ new_ver=${deb_ver%-*} ||
+ return 0
+
+ test "$ver" != "$new_ver"
+}
+
+cp -f m4/.gitignore debian/generated-m4.list
+cp -f po/.gitignore debian/generated-po.list
+sed -n 's,^build-aux/,, p' .gitignore > debian/generated-build-aux.list
+! changelog_needs_update || exec sh debian/changelog.upstream.sh