summaryrefslogtreecommitdiffstats
path: root/debug/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'debug/Makefile.am')
-rw-r--r--debug/Makefile.am30
1 files changed, 30 insertions, 0 deletions
diff --git a/debug/Makefile.am b/debug/Makefile.am
new file mode 100644
index 0000000..9026fd9
--- /dev/null
+++ b/debug/Makefile.am
@@ -0,0 +1,30 @@
+##
+## Author: Lasse Collin
+##
+## This file has been put into the public domain.
+## You can do whatever you want with this file.
+##
+
+EXTRA_DIST = \
+ translation.bash
+
+noinst_PROGRAMS = \
+ repeat \
+ sync_flush \
+ full_flush \
+ memusage \
+ crc32 \
+ known_sizes \
+ hex2bin
+
+AM_CPPFLAGS = \
+ -I$(top_srcdir)/src/common \
+ -I$(top_srcdir)/src/liblzma/api
+
+LDADD = $(top_builddir)/src/liblzma/liblzma.la
+
+if COND_GNULIB
+LDADD += $(top_builddir)/lib/libgnu.a
+endif
+
+LDADD += $(LTLIBINTL)