summaryrefslogtreecommitdiffstats
path: root/bin/tools
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-08 16:41:29 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-08 16:41:29 +0000
commite2fc8e037ea6bb5de92b25ec9c12a624737ac5ca (patch)
tree65e6bbf5e12c3fe09b43e577f8d1786d06bcd559 /bin/tools
parentReleasing progress-linux version 1:9.18.19-1~deb12u1progress7u1. (diff)
downloadbind9-e2fc8e037ea6bb5de92b25ec9c12a624737ac5ca.tar.xz
bind9-e2fc8e037ea6bb5de92b25ec9c12a624737ac5ca.zip
Merging upstream version 1:9.18.24.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'bin/tools')
-rw-r--r--bin/tools/Makefile.in2
-rw-r--r--bin/tools/dnstap-read.c13
2 files changed, 0 insertions, 15 deletions
diff --git a/bin/tools/Makefile.in b/bin/tools/Makefile.in
index aa0a14b..fb3ae04 100644
--- a/bin/tools/Makefile.in
+++ b/bin/tools/Makefile.in
@@ -112,11 +112,9 @@ am__aclocal_m4_deps = $(top_srcdir)/m4/ax_check_compile_flag.m4 \
$(top_srcdir)/m4/ax_gcc_func_attribute.m4 \
$(top_srcdir)/m4/ax_jemalloc.m4 \
$(top_srcdir)/m4/ax_lib_lmdb.m4 \
- $(top_srcdir)/m4/ax_perl_module.m4 \
$(top_srcdir)/m4/ax_posix_shell.m4 \
$(top_srcdir)/m4/ax_prog_cc_for_build.m4 \
$(top_srcdir)/m4/ax_pthread.m4 \
- $(top_srcdir)/m4/ax_python_module.m4 \
$(top_srcdir)/m4/ax_restore_flags.m4 \
$(top_srcdir)/m4/ax_save_flags.m4 $(top_srcdir)/m4/ax_tls.m4 \
$(top_srcdir)/m4/libtool.m4 $(top_srcdir)/m4/ltoptions.m4 \
diff --git a/bin/tools/dnstap-read.c b/bin/tools/dnstap-read.c
index f6abeeb..06dd561 100644
--- a/bin/tools/dnstap-read.c
+++ b/bin/tools/dnstap-read.c
@@ -327,7 +327,6 @@ int
main(int argc, char *argv[]) {
isc_result_t result;
dns_message_t *message = NULL;
- isc_buffer_t *b = NULL;
dns_dtdata_t *dt = NULL;
dns_dthandle_t *handle = NULL;
int rv = 0, ch;
@@ -380,17 +379,8 @@ main(int argc, char *argv[]) {
input.base = data;
input.length = datalen;
- if (b != NULL) {
- isc_buffer_free(&b);
- }
- isc_buffer_allocate(mctx, &b, 2048);
- if (b == NULL) {
- fatal("out of memory");
- }
-
result = dns_dt_parse(mctx, &input, &dt);
if (result != ISC_R_SUCCESS) {
- isc_buffer_free(&b);
continue;
}
@@ -419,9 +409,6 @@ cleanup:
if (message != NULL) {
dns_message_detach(&message);
}
- if (b != NULL) {
- isc_buffer_free(&b);
- }
isc_mem_destroy(&mctx);
exit(rv);