summaryrefslogtreecommitdiffstats
path: root/build/rust/env_logger
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
commit36d22d82aa202bb199967e9512281e9a53db42c9 (patch)
tree105e8c98ddea1c1e4784a60a5a6410fa416be2de /build/rust/env_logger
parentInitial commit. (diff)
downloadfirefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.tar.xz
firefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.zip
Adding upstream version 115.7.0esr.upstream/115.7.0esr
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'build/rust/env_logger')
-rw-r--r--build/rust/env_logger/Cargo.toml19
-rw-r--r--build/rust/env_logger/lib.rs5
2 files changed, 24 insertions, 0 deletions
diff --git a/build/rust/env_logger/Cargo.toml b/build/rust/env_logger/Cargo.toml
new file mode 100644
index 0000000000..1475b47e7f
--- /dev/null
+++ b/build/rust/env_logger/Cargo.toml
@@ -0,0 +1,19 @@
+[package]
+name = "env_logger"
+version = "0.9.999"
+edition = "2018"
+license = "MPL-2.0"
+
+[lib]
+path = "lib.rs"
+
+[dependencies.env_logger]
+version = "0.10"
+default-features = false
+
+[features]
+default = ["env_logger/default"]
+termcolor = ["env_logger/color"]
+atty = ["env_logger/auto-color"]
+humantime = ["env_logger/humantime"]
+regex = ["env_logger/regex"]
diff --git a/build/rust/env_logger/lib.rs b/build/rust/env_logger/lib.rs
new file mode 100644
index 0000000000..cd291d6351
--- /dev/null
+++ b/build/rust/env_logger/lib.rs
@@ -0,0 +1,5 @@
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this
+ * file, You can obtain one at http://mozilla.org/MPL/2.0/. */
+
+pub use env_logger::*;