summaryrefslogtreecommitdiffstats
path: root/build/rust/parking_lot
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
commit36d22d82aa202bb199967e9512281e9a53db42c9 (patch)
tree105e8c98ddea1c1e4784a60a5a6410fa416be2de /build/rust/parking_lot
parentInitial commit. (diff)
downloadfirefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.tar.xz
firefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.zip
Adding upstream version 115.7.0esr.upstream/115.7.0esr
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'build/rust/parking_lot')
-rw-r--r--build/rust/parking_lot/Cargo.toml11
-rw-r--r--build/rust/parking_lot/lib.rs5
2 files changed, 16 insertions, 0 deletions
diff --git a/build/rust/parking_lot/Cargo.toml b/build/rust/parking_lot/Cargo.toml
new file mode 100644
index 0000000000..adfdb58e57
--- /dev/null
+++ b/build/rust/parking_lot/Cargo.toml
@@ -0,0 +1,11 @@
+[package]
+name = "parking_lot"
+version = "0.12.999"
+edition = "2018"
+license = "MPL-2.0"
+
+[lib]
+path = "lib.rs"
+
+[dependencies]
+parking_lot = "0.11"
diff --git a/build/rust/parking_lot/lib.rs b/build/rust/parking_lot/lib.rs
new file mode 100644
index 0000000000..402ca1ee10
--- /dev/null
+++ b/build/rust/parking_lot/lib.rs
@@ -0,0 +1,5 @@
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this
+ * file, You can obtain one at http://mozilla.org/MPL/2.0/. */
+
+pub use parking_lot::*;