summaryrefslogtreecommitdiffstats
path: root/gfx/webrender_bindings/README.webrender
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
commit36d22d82aa202bb199967e9512281e9a53db42c9 (patch)
tree105e8c98ddea1c1e4784a60a5a6410fa416be2de /gfx/webrender_bindings/README.webrender
parentInitial commit. (diff)
downloadfirefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.tar.xz
firefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.zip
Adding upstream version 115.7.0esr.upstream/115.7.0esr
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'gfx/webrender_bindings/README.webrender')
-rw-r--r--gfx/webrender_bindings/README.webrender23
1 files changed, 23 insertions, 0 deletions
diff --git a/gfx/webrender_bindings/README.webrender b/gfx/webrender_bindings/README.webrender
new file mode 100644
index 0000000000..a42c33092d
--- /dev/null
+++ b/gfx/webrender_bindings/README.webrender
@@ -0,0 +1,23 @@
+To build and run WebRender in Gecko:
+1. Install Rust if you don't have it already
+ If you are doing gecko builds already, you should already have Rust as it is a build requirement.
+ If not, you can install it using |mach bootstrap| (recommended) or from https://www.rust-lang.org/
+ Note: If installing manually, use the stable 64-bit release - on Windows make sure to use the MSVC ABI installer.
+ Ensure that rustc and cargo are in your $PATH (adding $HOME/.cargo/bin/ should be sufficient)
+2. Build using |mach build|.
+ You don't need anything special in your mozconfig for local builds; webrender will be built by default.
+3. Run with |MOZ_WEBRENDER=1| in your environment. e.g. |MOZ_WEBRENDER=1 ./mach run|.
+ Alternatively, you can set the gfx.webrender.enabled pref to true (browser restart required).
+ Note that on Linux, acceleration is disabled by default and it needs to be enabled for WebRender to work.
+ On Linux you can enable acceleration by putting |MOZ_ACCELERATED=1| in your environment, or setting layers.acceleration.force-enabled to true in about:config.
+4. Verify WebRender is enabled. You can do this by going to about:support and checking the "Compositing" line in the Graphics section. It should say "WebRender".
+ There should also be a WebRender section under "Decision Log" in about:support, which will provide some more detail on what caused it to be enabled/disabled.
+
+When making changes:
+ - Make the changes you want.
+ - Run |mach build| or |mach build binaries| as desired.
+
+For a debug webrender build:
+ Use a debug mozconfig (ac_add_options --enable-debug)
+ You can also use an opt build but make webrender less optimized by putting opt-level=0 in the [profile.release] section of your toolkit/library/rust/Cargo.toml file
+ See also https://groups.google.com/forum/#!topic/mozilla.dev.servo/MbeMcqqO1fs