summaryrefslogtreecommitdiffstats
path: root/gfx/wr/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
commit36d22d82aa202bb199967e9512281e9a53db42c9 (patch)
tree105e8c98ddea1c1e4784a60a5a6410fa416be2de /gfx/wr/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.tar.xz
firefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.zip
Adding upstream version 115.7.0esr.upstream/115.7.0esr
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'gfx/wr/Cargo.toml')
-rw-r--r--gfx/wr/Cargo.toml27
1 files changed, 27 insertions, 0 deletions
diff --git a/gfx/wr/Cargo.toml b/gfx/wr/Cargo.toml
new file mode 100644
index 0000000000..6be188c09c
--- /dev/null
+++ b/gfx/wr/Cargo.toml
@@ -0,0 +1,27 @@
+[workspace]
+members = [
+ "examples",
+ "webrender",
+ "webrender_api",
+ "wrench",
+ "example-compositor/compositor",
+]
+
+[profile.release]
+debug = true
+panic = "abort"
+
+[profile.dev]
+panic = "abort"
+
+# optimizing glsl more makes a big difference in swgl build times
+[profile.dev.package.glsl]
+opt-level = 2
+
+[profile.release.package.glsl]
+opt-level = 2
+
+[patch.crates-io]
+firefox-on-glean = { path = "fog" }
+# use a patched version of glutin that works on android
+glutin = { version = "0.28", git = "https://github.com/jamienicol/glutin", branch="wr" }