summaryrefslogtreecommitdiffstats
path: root/ipc/ipdl/Makefile.in
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
commit36d22d82aa202bb199967e9512281e9a53db42c9 (patch)
tree105e8c98ddea1c1e4784a60a5a6410fa416be2de /ipc/ipdl/Makefile.in
parentInitial commit. (diff)
downloadfirefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.tar.xz
firefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.zip
Adding upstream version 115.7.0esr.upstream/115.7.0esr
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'ipc/ipdl/Makefile.in')
-rw-r--r--ipc/ipdl/Makefile.in33
1 files changed, 33 insertions, 0 deletions
diff --git a/ipc/ipdl/Makefile.in b/ipc/ipdl/Makefile.in
new file mode 100644
index 0000000000..7a4d2acfba
--- /dev/null
+++ b/ipc/ipdl/Makefile.in
@@ -0,0 +1,33 @@
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+
+ifdef COMPILE_ENVIRONMENT
+
+# This file is generated by the moz.build backend.
+include ipdlsrcs.mk
+
+include $(topsrcdir)/config/rules.mk
+
+ipdl_py_deps := \
+ $(wildcard $(srcdir)/*.py) \
+ $(wildcard $(srcdir)/ipdl/*.py) \
+ $(wildcard $(srcdir)/ipdl/cxx/*.py) \
+ $(wildcard $(topsrcdir)/other-licenses/ply/ply/*.py) \
+ $(NULL)
+
+# NB: the IPDL compiler manages .ipdl-->.h/.cpp dependencies itself,
+# which is why we don't have explicit .h/.cpp targets here
+ipdl.track: $(ALL_IPDLSRCS) $(srcdir)/sync-messages.ini $(srcdir)/message-metadata.ini $(ipdl_py_deps)
+ $(PYTHON3) $(srcdir)/ipdl.py \
+ --sync-msg-list=$(srcdir)/sync-messages.ini \
+ --msg-metadata=$(srcdir)/message-metadata.ini \
+ --outheaders-dir=_ipdlheaders \
+ --outcpp-dir=. \
+ $(IPDLDIRS:%=-I%) \
+ $(ALL_IPDLSRCS)
+ touch $@
+
+export:: ipdl.track
+endif
+