summaryrefslogtreecommitdiffstats
path: root/testing/condprofile/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
commit36d22d82aa202bb199967e9512281e9a53db42c9 (patch)
tree105e8c98ddea1c1e4784a60a5a6410fa416be2de /testing/condprofile/Makefile
parentInitial commit. (diff)
downloadfirefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.tar.xz
firefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.zip
Adding upstream version 115.7.0esr.upstream/115.7.0esr
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'testing/condprofile/Makefile')
-rw-r--r--testing/condprofile/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/testing/condprofile/Makefile b/testing/condprofile/Makefile
new file mode 100644
index 0000000000..b626f5c7e9
--- /dev/null
+++ b/testing/condprofile/Makefile
@@ -0,0 +1,23 @@
+HERE = $(shell pwd)
+BIN = $(HERE)/bin
+PYTHON = $(BIN)/python
+INSTALL = $(BIN)/pip install --no-deps
+BUILD_DIRS = bin build include lib lib64 man share
+VIRTUALENV = virtualenv
+
+.PHONY: all test build docs
+
+all: build
+
+$(PYTHON):
+ $(VIRTUALENV) $(VTENV_OPTS) .
+
+build: $(PYTHON)
+ $(PYTHON) setup.py develop
+ $(BIN)/pip install tox
+
+test: build
+ $(BIN)/tox
+
+docs: build
+ $(BIN)/tox -e docs