summaryrefslogtreecommitdiffstats
path: root/testing/talos/setup.py
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
commit36d22d82aa202bb199967e9512281e9a53db42c9 (patch)
tree105e8c98ddea1c1e4784a60a5a6410fa416be2de /testing/talos/setup.py
parentInitial commit. (diff)
downloadfirefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.tar.xz
firefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.zip
Adding upstream version 115.7.0esr.upstream/115.7.0esr
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'testing/talos/setup.py')
-rw-r--r--testing/talos/setup.py68
1 files changed, 68 insertions, 0 deletions
diff --git a/testing/talos/setup.py b/testing/talos/setup.py
new file mode 100644
index 0000000000..628610f077
--- /dev/null
+++ b/testing/talos/setup.py
@@ -0,0 +1,68 @@
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this
+# file, You can obtain one at http://mozilla.org/MPL/2.0/.
+
+import os
+
+from setuptools import find_packages, setup
+
+try:
+ here = os.path.dirname(os.path.abspath(__file__))
+ description = open(os.path.join(here, "README")).read()
+except OSError:
+ description = ""
+
+version = "0.0"
+
+with open(os.path.join(here, "requirements.txt")) as f:
+ dependencies = f.read().splitlines()
+
+dependency_links = []
+
+setup(
+ name="talos",
+ version=version,
+ description="Performance testing framework for Windows, Mac and Linux.",
+ long_description=description,
+ classifiers=[
+ "Programming Language :: Python :: 2.7",
+ "Programming Language :: Python :: 2 :: Only",
+ ],
+ # Get strings from http://www.python.org/pypi?%3Aaction=list_classifiers
+ author="Mozilla Foundation",
+ author_email="tools@lists.mozilla.org",
+ url="https://wiki.mozilla.org/Buildbot/Talos",
+ license="MPL",
+ packages=find_packages(exclude=["ez_setup", "examples", "tests"]),
+ include_package_data=True,
+ package_data={
+ "": [
+ "*.config",
+ "*.css",
+ "*.gif",
+ "*.htm",
+ "*.html",
+ "*.ico",
+ "*.js",
+ "*.json",
+ "*.manifest",
+ "*.php",
+ "*.png",
+ "*.rdf",
+ "*.sqlite",
+ "*.svg",
+ "*.xml",
+ "*.xul",
+ ]
+ },
+ zip_safe=False,
+ install_requires=dependencies,
+ dependency_links=dependency_links,
+ entry_points="""
+ # -*- Entry points: -*-
+ [console_scripts]
+ talos = talos.run_tests:main
+ talos-results = talos.results:main
+ """,
+ test_suite="tests",
+)