summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/compat/webkit-linear-gradient-line-top.html
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
commit36d22d82aa202bb199967e9512281e9a53db42c9 (patch)
tree105e8c98ddea1c1e4784a60a5a6410fa416be2de /testing/web-platform/tests/compat/webkit-linear-gradient-line-top.html
parentInitial commit. (diff)
downloadfirefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.tar.xz
firefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.zip
Adding upstream version 115.7.0esr.upstream/115.7.0esr
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'testing/web-platform/tests/compat/webkit-linear-gradient-line-top.html')
-rw-r--r--testing/web-platform/tests/compat/webkit-linear-gradient-line-top.html23
1 files changed, 23 insertions, 0 deletions
diff --git a/testing/web-platform/tests/compat/webkit-linear-gradient-line-top.html b/testing/web-platform/tests/compat/webkit-linear-gradient-line-top.html
new file mode 100644
index 0000000000..61d205a700
--- /dev/null
+++ b/testing/web-platform/tests/compat/webkit-linear-gradient-line-top.html
@@ -0,0 +1,23 @@
+<!doctype html>
+<title>-webkit-linear-gradient(top)</title>
+<link rel="author" title="Xidorn Quan" href="me@upsuper.org">
+<link rel="author" title="Mozilla" href="https://www.mozilla.org">
+<link rel="help" href="https://compat.spec.whatwg.org/#css-gradients-webkit-linear-gradient">
+<meta name="assert" content="'top' in -webkit-linear-gradient is equivalent to 'to bottom' in modern syntax">
+<link rel="match" href="green-ref.html">
+<meta name="fuzzy" content="maxDifference=0-1; totalPixels=0-4400">
+<style>
+ #outer {
+ width: 100px;
+ height: 100px;
+ overflow: hidden;
+ }
+ #inner {
+ width: 100px;
+ height: 200px;
+ background-image: -webkit-linear-gradient(top, green 50%, red 50%);
+ }
+</style>
+<div id="outer">
+ <div id="inner"></div>
+</div>