summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/conformance-checkers/html/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
commit36d22d82aa202bb199967e9512281e9a53db42c9 (patch)
tree105e8c98ddea1c1e4784a60a5a6410fa416be2de /testing/web-platform/tests/conformance-checkers/html/Makefile
parentInitial commit. (diff)
downloadfirefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.tar.xz
firefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.zip
Adding upstream version 115.7.0esr.upstream/115.7.0esr
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'testing/web-platform/tests/conformance-checkers/html/Makefile')
-rw-r--r--testing/web-platform/tests/conformance-checkers/html/Makefile20
1 files changed, 20 insertions, 0 deletions
diff --git a/testing/web-platform/tests/conformance-checkers/html/Makefile b/testing/web-platform/tests/conformance-checkers/html/Makefile
new file mode 100644
index 0000000000..332591348f
--- /dev/null
+++ b/testing/web-platform/tests/conformance-checkers/html/Makefile
@@ -0,0 +1,20 @@
+PYTHON=python
+PYTHONFLAGS=
+META_EXTENSIONS=http://help.whatwg.org/extensions/meta-name/
+CURL=curl
+CURLFLAGS=
+PYTHON=python
+PYTHONFLAGS=
+
+.PHONY: ins-del-datetime .FORCE
+
+all: ins-del-datetime tools/meta-extensions elements/meta/names-registered-isvalid.html
+
+ins-del-datetime: tools/ins-del-datetime.py
+ $(PYTHON) $(PYTHONFLAGS) $<
+
+tools/meta-extensions: .FORCE
+ $(CURL) $(CURLFLAGS) $(META_EXTENSIONS) > $@
+
+elements/meta/names-registered-isvalid.html: .FORCE
+ $(PYTHON) $(PYTHONFLAGS) tools/meta-name.py