summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/html/semantics/popovers/popover-document-open.html
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
commit36d22d82aa202bb199967e9512281e9a53db42c9 (patch)
tree105e8c98ddea1c1e4784a60a5a6410fa416be2de /testing/web-platform/tests/html/semantics/popovers/popover-document-open.html
parentInitial commit. (diff)
downloadfirefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.tar.xz
firefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.zip
Adding upstream version 115.7.0esr.upstream/115.7.0esr
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'testing/web-platform/tests/html/semantics/popovers/popover-document-open.html')
-rw-r--r--testing/web-platform/tests/html/semantics/popovers/popover-document-open.html30
1 files changed, 30 insertions, 0 deletions
diff --git a/testing/web-platform/tests/html/semantics/popovers/popover-document-open.html b/testing/web-platform/tests/html/semantics/popovers/popover-document-open.html
new file mode 100644
index 0000000000..80ac86aced
--- /dev/null
+++ b/testing/web-platform/tests/html/semantics/popovers/popover-document-open.html
@@ -0,0 +1,30 @@
+<!DOCTYPE html>
+<meta charset="utf-8">
+<link rel="author" href="mailto:masonf@chromium.org">
+<link rel=help href="https://open-ui.org/components/popover.research.explainer">
+<link rel=help href="https://html.spec.whatwg.org/multipage/popover.html">
+<script src="/resources/testharness.js"></script>
+<script src="/resources/testharnessreport.js"></script>
+
+<div popover id=popover1>Popover</div>
+
+<script>
+ window.onload = () => {
+ test((t) => {
+ const popover1 = document.querySelector('#popover1');
+ popover1.showPopover();
+ assert_true(popover1.matches(':popover-open'));
+ assert_true(!document.querySelector('#popover2'));
+ document.open();
+ document.write('<!DOCTYPE html><div popover id=popover2>Popover</div>');
+ document.close();
+ assert_true(!document.querySelector('#popover1'),'popover1 should be removed from the document');
+ assert_true(!!document.querySelector('#popover2'),'popover2 should be in the document');
+ assert_false(popover1.matches(':popover-open'),'popover1 should have been hidden when it was removed from the document');
+ assert_false(popover1.matches(':popover-open'),'popover2 shouldn\'t be showing yet');
+ popover2.showPopover();
+ assert_true(popover2.matches(':popover-open'),'popover2 should be able to be shown');
+ popover2.hidePopover();
+ },'document.open should not break popovers');
+ };
+</script>