summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/html/semantics/popovers/popover-not-keyboard-focusable.html
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
commit36d22d82aa202bb199967e9512281e9a53db42c9 (patch)
tree105e8c98ddea1c1e4784a60a5a6410fa416be2de /testing/web-platform/tests/html/semantics/popovers/popover-not-keyboard-focusable.html
parentInitial commit. (diff)
downloadfirefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.tar.xz
firefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.zip
Adding upstream version 115.7.0esr.upstream/115.7.0esr
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'testing/web-platform/tests/html/semantics/popovers/popover-not-keyboard-focusable.html')
-rw-r--r--testing/web-platform/tests/html/semantics/popovers/popover-not-keyboard-focusable.html49
1 files changed, 49 insertions, 0 deletions
diff --git a/testing/web-platform/tests/html/semantics/popovers/popover-not-keyboard-focusable.html b/testing/web-platform/tests/html/semantics/popovers/popover-not-keyboard-focusable.html
new file mode 100644
index 0000000000..55c70aa643
--- /dev/null
+++ b/testing/web-platform/tests/html/semantics/popovers/popover-not-keyboard-focusable.html
@@ -0,0 +1,49 @@
+<!DOCTYPE html>
+<meta charset="utf-8" />
+<title>Popover keyboard focus behaviors</title>
+<link rel="author" href="mailto:masonf@chromium.org">
+<link rel=help href="https://open-ui.org/components/popover.research.explainer">
+<link rel=help href="https://html.spec.whatwg.org/multipage/popover.html">
+<script src="/resources/testharness.js"></script>
+<script src="/resources/testharnessreport.js"></script>
+<script src="/resources/testdriver.js"></script>
+<script src="/resources/testdriver-actions.js"></script>
+<script src="/resources/testdriver-vendor.js"></script>
+
+<button id=firstfocus tabindex="0">Button 1</button>
+<div popover>
+ <p>This is a popover without a focusable element</p>
+</div>
+<button id=secondfocus tabindex="0">Button 2</button>
+
+<script>
+promise_test(async () => {
+ const b1 = document.getElementById('firstfocus');
+ const b2 = document.getElementById('secondfocus');
+ const popover = document.querySelector('[popover]');
+ b1.focus();
+ assert_equals(document.activeElement,b1);
+ popover.showPopover();
+ assert_true(popover.matches(':popover-open'));
+ assert_equals(document.activeElement,b1);
+ // Tab once
+ await new test_driver.send_keys(document.body,'\uE004'); // Tab
+ assert_equals(document.activeElement, b2, 'Keyboard focus should skip the open popover');
+ assert_true(popover.matches(':popover-open'),'changing focus should not close the popover');
+ popover.hidePopover();
+
+ // Add a focusable button to the popover and make sure we can focus that
+ const button = document.createElement('button');
+ button.setAttribute("tabindex", "0");
+ popover.appendChild(button);
+ b1.focus();
+ popover.showPopover();
+ assert_equals(document.activeElement,b1);
+ // Tab once
+ await new test_driver.send_keys(document.body,'\uE004'); // Tab
+ assert_equals(document.activeElement, button, 'Keyboard focus should go to the contained button');
+ assert_true(popover.matches(':popover-open'),'changing focus to the popover should leave it showing');
+ popover.hidePopover();
+ assert_false(popover.matches(':popover-open'));
+}, "Popover should not be keyboard focusable");
+</script>