summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/html/syntax/parsing/the-end.html
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
commit36d22d82aa202bb199967e9512281e9a53db42c9 (patch)
tree105e8c98ddea1c1e4784a60a5a6410fa416be2de /testing/web-platform/tests/html/syntax/parsing/the-end.html
parentInitial commit. (diff)
downloadfirefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.tar.xz
firefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.zip
Adding upstream version 115.7.0esr.upstream/115.7.0esr
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'testing/web-platform/tests/html/syntax/parsing/the-end.html')
-rw-r--r--testing/web-platform/tests/html/syntax/parsing/the-end.html59
1 files changed, 59 insertions, 0 deletions
diff --git a/testing/web-platform/tests/html/syntax/parsing/the-end.html b/testing/web-platform/tests/html/syntax/parsing/the-end.html
new file mode 100644
index 0000000000..79e32bb912
--- /dev/null
+++ b/testing/web-platform/tests/html/syntax/parsing/the-end.html
@@ -0,0 +1,59 @@
+<!doctype html>
+<meta charset=utf-8>
+<title>The end</title>
+<link rel=help href="https://html.spec.whatwg.org/multipage/#the-end">
+<script src="/resources/testharness.js"></script>
+<script src="/resources/testharnessreport.js"></script>
+<div id="log"></div>
+<script>
+async_test(function() {
+ document.addEventListener("DOMContentLoaded", this.step_func_done(function(e) {
+ assert_equals(e.type, "DOMContentLoaded");
+ assert_true(e.bubbles, "bubbles should be true");
+ assert_false(e.cancelable, "cancelable should be false");
+ assert_equals(e.target, document, "target should be document");
+ assert_true(e.isTrusted, "isTrusted should be true");
+ assert_class_string(e, "Event");
+ }));
+}, "DOMContentLoaded");
+
+async_test(function() {
+ window.addEventListener("load", this.step_func_done(function(e) {
+ assert_equals(e.type, "load");
+ assert_false(e.bubbles, "bubbles should be false");
+ assert_false(e.cancelable, "cancelable should be false");
+ assert_equals(e.target, document, "target should be document");
+ assert_true(e.isTrusted, "isTrusted should be true");
+ assert_class_string(e, "Event");
+ }));
+}, "load");
+
+async_test(function() {
+ window.addEventListener("pageshow", this.step_func_done(function(e) {
+ assert_equals(e.type, "pageshow");
+
+ // https://github.com/whatwg/html/issues/6794
+ assert_true(e.bubbles, "bubbles should be true");
+ assert_true(e.cancelable, "cancelable should be true");
+
+ assert_equals(e.target, document, "target should be document");
+ assert_true(e.isTrusted, "isTrusted should be true");
+ assert_class_string(e, "PageTransitionEvent");
+ }));
+}, "pageshow");
+
+async_test(function() {
+ var seen_dcl = false;
+ var seen_load = false;
+ document.addEventListener("DOMContentLoaded", this.step_func(function() {
+ seen_dcl = true;
+ }));
+ window.addEventListener("load", this.step_func(function() {
+ seen_load = true;
+ assert_true(seen_dcl, "DOMContentLoaded should be fired before load");
+ }));
+ window.addEventListener("pageshow", this.step_func_done(function() {
+ assert_true(seen_load, "load should be fired before pageshow")
+ }));
+}, "order");
+</script>