summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/navigation-timing/dom-interactive-image-document.html
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
commit36d22d82aa202bb199967e9512281e9a53db42c9 (patch)
tree105e8c98ddea1c1e4784a60a5a6410fa416be2de /testing/web-platform/tests/navigation-timing/dom-interactive-image-document.html
parentInitial commit. (diff)
downloadfirefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.tar.xz
firefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.zip
Adding upstream version 115.7.0esr.upstream/115.7.0esr
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'testing/web-platform/tests/navigation-timing/dom-interactive-image-document.html')
-rw-r--r--testing/web-platform/tests/navigation-timing/dom-interactive-image-document.html25
1 files changed, 25 insertions, 0 deletions
diff --git a/testing/web-platform/tests/navigation-timing/dom-interactive-image-document.html b/testing/web-platform/tests/navigation-timing/dom-interactive-image-document.html
new file mode 100644
index 0000000000..36742f0eff
--- /dev/null
+++ b/testing/web-platform/tests/navigation-timing/dom-interactive-image-document.html
@@ -0,0 +1,25 @@
+<!DOCTYPE html>
+<html>
+ <head>
+ <meta charset="utf-8" />
+ <title>Test domInteractive on image document.</title>
+ <link rel="author" title="Google" href="http://www.google.com/" />
+ <link rel="help" href="https://html.spec.whatwg.org/multipage/browsing-the-web.html#read-media"/>
+ <script src="/resources/testharness.js"></script>
+ <script src="/resources/testharnessreport.js"></script>
+ </head>
+ <script>
+ const t = async_test("Test domInteractive on image document");
+ function frameLoaded() {
+ const timing = document.querySelector("iframe").contentWindow.performance.timing;
+ assert_greater_than(timing.domInteractive, 0,
+ "Expect domInteractive to be positive value.");
+ t.done();
+ }
+ </script>
+ <body>
+ <h1>Description</h1>
+ <p>This tests that a image document has positive-value domInteractive.</p>
+ <iframe src="../images/smiley.png" onload="frameLoaded()"></iframe>
+ </body>
+</html> \ No newline at end of file