summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/xhr/xmlhttprequest-timeout-overrides.html
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
commit36d22d82aa202bb199967e9512281e9a53db42c9 (patch)
tree105e8c98ddea1c1e4784a60a5a6410fa416be2de /testing/web-platform/tests/xhr/xmlhttprequest-timeout-overrides.html
parentInitial commit. (diff)
downloadfirefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.tar.xz
firefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.zip
Adding upstream version 115.7.0esr.upstream/115.7.0esr
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'testing/web-platform/tests/xhr/xmlhttprequest-timeout-overrides.html')
-rw-r--r--testing/web-platform/tests/xhr/xmlhttprequest-timeout-overrides.html26
1 files changed, 26 insertions, 0 deletions
diff --git a/testing/web-platform/tests/xhr/xmlhttprequest-timeout-overrides.html b/testing/web-platform/tests/xhr/xmlhttprequest-timeout-overrides.html
new file mode 100644
index 0000000000..afebfe7bc4
--- /dev/null
+++ b/testing/web-platform/tests/xhr/xmlhttprequest-timeout-overrides.html
@@ -0,0 +1,26 @@
+ <!DOCTYPE html>
+<html>
+<head>
+ <meta charset="utf-8" />
+ <title>XHR2 Timeout Property Tests</title>
+ <link rel="help" href="https://xhr.spec.whatwg.org/#the-timeout-attribute" data-tested-assertations="following::ol[1]/li[2]" />
+ <link rel="help" href="https://xhr.spec.whatwg.org/#handler-xhr-ontimeout" data-tested-assertations="../.."/>
+ <link rel="help" href="https://xhr.spec.whatwg.org/#timeout-error" data-tested-assertations=".."/>
+ <link rel="help" href="https://xhr.spec.whatwg.org/#request-error" data-tested-assertations="following::ol[1]/li[9]"/>
+ <meta name=timeout content=long>
+ <meta name=variant content="?timeout disabled after initially set">
+ <meta name=variant content="?timeout overrides load after a delay">
+ <meta name=variant content="?timeout enabled after initially disabled">
+ <script src="/resources/testharness.js"></script>
+ <script src="/resources/testharnessreport.js"></script>
+ <script src="resources/xmlhttprequest-timeout.js"></script>
+ <script src="resources/xmlhttprequest-timeout-runner.js"></script>
+</head>
+<body>
+ <h1>Description</h1>
+ <p>This test validates that the XHR2 timeout property behaves as expected in async cases in document (i.e. non-worker) context.</p>
+ <div id="log"></div>
+ <script src="resources/xmlhttprequest-timeout-overrides.js"></script>
+</body>
+</html>
+