summaryrefslogtreecommitdiffstats
path: root/third_party/python/PyYAML/README.md
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-08 15:11:27 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-08 15:11:27 +0000
commitf3bcaf9f88aad2c423ebcd61121562f9834187d4 (patch)
treef22238c29b57707b645a350940e3e9bdf3ce1f5d /third_party/python/PyYAML/README.md
parentAdding debian version 115.7.0esr-1~deb12u1. (diff)
downloadfirefox-esr-f3bcaf9f88aad2c423ebcd61121562f9834187d4.tar.xz
firefox-esr-f3bcaf9f88aad2c423ebcd61121562f9834187d4.zip
Merging upstream version 115.8.0esr.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/python/PyYAML/README.md')
-rw-r--r--third_party/python/PyYAML/README.md53
1 files changed, 53 insertions, 0 deletions
diff --git a/third_party/python/PyYAML/README.md b/third_party/python/PyYAML/README.md
new file mode 100644
index 0000000000..7d01da248f
--- /dev/null
+++ b/third_party/python/PyYAML/README.md
@@ -0,0 +1,53 @@
+PyYAML
+======
+
+A full-featured YAML processing framework for Python
+
+## Installation
+
+To install, type `python setup.py install`.
+
+By default, the `setup.py` script checks whether LibYAML is installed and if
+so, builds and installs LibYAML bindings.
+To skip the check and force installation of LibYAML bindings, use the option
+`--with-libyaml`: `python setup.py --with-libyaml install`.
+To disable the check and skip building and installing LibYAML bindings, use
+`--without-libyaml`: `python setup.py --without-libyaml install`.
+
+When LibYAML bindings are installed, you may use fast LibYAML-based parser and
+emitter as follows:
+
+ >>> yaml.load(stream, Loader=yaml.CLoader)
+ >>> yaml.dump(data, Dumper=yaml.CDumper)
+
+If you don't trust the input YAML stream, you should use:
+
+ >>> yaml.safe_load(stream)
+
+## Testing
+
+PyYAML includes a comprehensive test suite.
+To run the tests, type `python setup.py test`.
+
+## Further Information
+
+* For more information, check the
+ [PyYAML homepage](https://github.com/yaml/pyyaml).
+
+* [PyYAML tutorial and reference](http://pyyaml.org/wiki/PyYAMLDocumentation).
+
+* Discuss PyYAML with the maintainers on
+ Matrix at https://matrix.to/#/#pyyaml:yaml.io or
+ IRC #pyyaml irc.libera.chat
+
+* Submit bug reports and feature requests to the
+ [PyYAML bug tracker](https://github.com/yaml/pyyaml/issues).
+
+## License
+
+The PyYAML module was written by Kirill Simonov <xi@resolvent.net>.
+It is currently maintained by the YAML and Python communities.
+
+PyYAML is released under the MIT license.
+
+See the file LICENSE for more details.