summaryrefslogtreecommitdiffstats
path: root/third_party/rust/ash/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
commit36d22d82aa202bb199967e9512281e9a53db42c9 (patch)
tree105e8c98ddea1c1e4784a60a5a6410fa416be2de /third_party/rust/ash/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.tar.xz
firefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.zip
Adding upstream version 115.7.0esr.upstream/115.7.0esr
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/ash/Cargo.toml')
-rw-r--r--third_party/rust/ash/Cargo.toml53
1 files changed, 53 insertions, 0 deletions
diff --git a/third_party/rust/ash/Cargo.toml b/third_party/rust/ash/Cargo.toml
new file mode 100644
index 0000000000..429cbf7b24
--- /dev/null
+++ b/third_party/rust/ash/Cargo.toml
@@ -0,0 +1,53 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+rust-version = "1.59.0"
+name = "ash"
+version = "0.37.2+1.3.238"
+authors = [
+ "Maik Klein <maikklein@googlemail.com>",
+ "Benjamin Saunders <ben.e.saunders@gmail.com>",
+ "Marijn Suijten <marijn@traverseresearch.nl>",
+]
+description = "Vulkan bindings for Rust"
+documentation = "https://docs.rs/ash"
+readme = "README.md"
+keywords = [
+ "vulkan",
+ "graphic",
+]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/MaikKlein/ash"
+
+[package.metadata.release]
+no-dev-version = true
+
+[package.metadata.docs.rs]
+all-features = true
+rustdoc-args = [
+ "--cfg",
+ "docsrs",
+]
+
+[dependencies.libloading]
+version = "0.7"
+optional = true
+
+[features]
+debug = []
+default = [
+ "loaded",
+ "debug",
+]
+linked = []
+loaded = ["libloading"]