summaryrefslogtreecommitdiffstats
path: root/third_party/rust/bit-vec/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
commit36d22d82aa202bb199967e9512281e9a53db42c9 (patch)
tree105e8c98ddea1c1e4784a60a5a6410fa416be2de /third_party/rust/bit-vec/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.tar.xz
firefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.zip
Adding upstream version 115.7.0esr.upstream/115.7.0esr
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/bit-vec/Cargo.toml')
-rw-r--r--third_party/rust/bit-vec/Cargo.toml42
1 files changed, 42 insertions, 0 deletions
diff --git a/third_party/rust/bit-vec/Cargo.toml b/third_party/rust/bit-vec/Cargo.toml
new file mode 100644
index 0000000000..8c53de3e7e
--- /dev/null
+++ b/third_party/rust/bit-vec/Cargo.toml
@@ -0,0 +1,42 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+name = "bit-vec"
+version = "0.6.3"
+authors = ["Alexis Beingessner <a.beingessner@gmail.com>"]
+description = "A vector of bits"
+homepage = "https://github.com/contain-rs/bit-vec"
+documentation = "https://contain-rs.github.io/bit-vec/bit_vec"
+readme = "README.md"
+keywords = ["data-structures", "bitvec", "bitmask", "bitmap", "bit"]
+license = "MIT/Apache-2.0"
+repository = "https://github.com/contain-rs/bit-vec"
+[dependencies.serde]
+version = "1.0"
+features = ["derive"]
+optional = true
+default-features = false
+[dev-dependencies.rand]
+version = "0.7"
+
+[dev-dependencies.rand_xorshift]
+version = "0.2"
+
+[dev-dependencies.serde_json]
+version = "1.0"
+
+[features]
+default = ["std"]
+serde_no_std = ["serde/alloc"]
+serde_std = ["std", "serde/std"]
+std = []