summaryrefslogtreecommitdiffstats
path: root/third_party/rust/bytes/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
commit36d22d82aa202bb199967e9512281e9a53db42c9 (patch)
tree105e8c98ddea1c1e4784a60a5a6410fa416be2de /third_party/rust/bytes/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.tar.xz
firefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.zip
Adding upstream version 115.7.0esr.upstream/115.7.0esr
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/bytes/Cargo.toml')
-rw-r--r--third_party/rust/bytes/Cargo.toml54
1 files changed, 54 insertions, 0 deletions
diff --git a/third_party/rust/bytes/Cargo.toml b/third_party/rust/bytes/Cargo.toml
new file mode 100644
index 0000000000..d0acb34216
--- /dev/null
+++ b/third_party/rust/bytes/Cargo.toml
@@ -0,0 +1,54 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "bytes"
+version = "1.4.0"
+authors = [
+ "Carl Lerche <me@carllerche.com>",
+ "Sean McArthur <sean@seanmonstar.com>",
+]
+description = "Types and traits for working with bytes"
+readme = "README.md"
+keywords = [
+ "buffers",
+ "zero-copy",
+ "io",
+]
+categories = [
+ "network-programming",
+ "data-structures",
+]
+license = "MIT"
+repository = "https://github.com/tokio-rs/bytes"
+
+[package.metadata.docs.rs]
+rustdoc-args = [
+ "--cfg",
+ "docsrs",
+]
+
+[dependencies.serde]
+version = "1.0.60"
+features = ["alloc"]
+optional = true
+default-features = false
+
+[dev-dependencies.serde_test]
+version = "1.0"
+
+[features]
+default = ["std"]
+std = []
+
+[target."cfg(loom)".dev-dependencies.loom]
+version = "0.5"