summaryrefslogtreecommitdiffstats
path: root/third_party/rust/coreaudio-sys/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
commit36d22d82aa202bb199967e9512281e9a53db42c9 (patch)
tree105e8c98ddea1c1e4784a60a5a6410fa416be2de /third_party/rust/coreaudio-sys/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.tar.xz
firefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.zip
Adding upstream version 115.7.0esr.upstream/115.7.0esr
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/coreaudio-sys/Cargo.toml')
-rw-r--r--third_party/rust/coreaudio-sys/Cargo.toml55
1 files changed, 55 insertions, 0 deletions
diff --git a/third_party/rust/coreaudio-sys/Cargo.toml b/third_party/rust/coreaudio-sys/Cargo.toml
new file mode 100644
index 0000000000..8a339dbbef
--- /dev/null
+++ b/third_party/rust/coreaudio-sys/Cargo.toml
@@ -0,0 +1,55 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+name = "coreaudio-sys"
+version = "0.2.12"
+authors = ["Mitchell Nordine <mitchell.nordine@gmail.com>"]
+build = "build.rs"
+description = "Bindings for Apple's CoreAudio frameworks generated via rust-bindgen"
+homepage = "https://github.com/RustAudio/coreaudio-sys"
+readme = "README.md"
+keywords = [
+ "core",
+ "audio",
+ "unit",
+ "osx",
+ "ios",
+]
+license = "MIT"
+repository = "https://github.com/RustAudio/coreaudio-sys.git"
+
+[package.metadata.docs.rs]
+all-features = true
+default-target = "x86_64-apple-darwin"
+targets = [
+ "x86_64-apple-darwin",
+ "x86_64-apple-ios",
+]
+
+[build-dependencies.bindgen]
+version = "0.64"
+features = ["runtime"]
+default-features = false
+
+[features]
+audio_toolbox = []
+audio_unit = []
+core_audio = []
+core_midi = []
+default = [
+ "audio_toolbox",
+ "audio_unit",
+ "core_audio",
+ "open_al",
+ "core_midi",
+]
+open_al = []