summaryrefslogtreecommitdiffstats
path: root/third_party/rust/cssparser/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
commit36d22d82aa202bb199967e9512281e9a53db42c9 (patch)
tree105e8c98ddea1c1e4784a60a5a6410fa416be2de /third_party/rust/cssparser/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.tar.xz
firefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.zip
Adding upstream version 115.7.0esr.upstream/115.7.0esr
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/cssparser/Cargo.toml')
-rw-r--r--third_party/rust/cssparser/Cargo.toml75
1 files changed, 75 insertions, 0 deletions
diff --git a/third_party/rust/cssparser/Cargo.toml b/third_party/rust/cssparser/Cargo.toml
new file mode 100644
index 0000000000..eeef7565b8
--- /dev/null
+++ b/third_party/rust/cssparser/Cargo.toml
@@ -0,0 +1,75 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+rust-version = "1.63"
+name = "cssparser"
+version = "0.31.0"
+authors = ["Simon Sapin <simon.sapin@exyr.org>"]
+exclude = [
+ "src/css-parsing-tests/**",
+ "src/big-data-url.css",
+]
+description = "Rust implementation of CSS Syntax Level 3"
+documentation = "https://docs.rs/cssparser/"
+readme = "README.md"
+keywords = [
+ "css",
+ "syntax",
+ "parser",
+]
+license = "MPL-2.0"
+repository = "https://github.com/servo/rust-cssparser"
+
+[dependencies]
+dtoa-short = "0.3"
+itoa = "1.0"
+smallvec = "1.0"
+
+[dependencies.cssparser-macros]
+version = "0.6"
+
+[dependencies.phf]
+version = ">=0.8,<=0.11"
+features = ["macros"]
+
+[dependencies.serde]
+version = "1.0"
+optional = true
+
+[dev-dependencies]
+difference = "2.0"
+encoding_rs = "0.8"
+serde_json = "1.0"
+
+[build-dependencies]
+proc-macro2 = "1"
+quote = "1"
+
+[build-dependencies.syn]
+version = "1"
+features = [
+ "extra-traits",
+ "fold",
+ "full",
+]
+
+[features]
+bench = []
+dummy_match_byte = []
+
+[workspace]
+members = [
+ ".",
+ "./macros",
+ "./procedural-masquerade",
+]