summaryrefslogtreecommitdiffstats
path: root/third_party/rust/flagset/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
commit36d22d82aa202bb199967e9512281e9a53db42c9 (patch)
tree105e8c98ddea1c1e4784a60a5a6410fa416be2de /third_party/rust/flagset/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.tar.xz
firefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.zip
Adding upstream version 115.7.0esr.upstream/115.7.0esr
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/flagset/Cargo.toml')
-rw-r--r--third_party/rust/flagset/Cargo.toml34
1 files changed, 34 insertions, 0 deletions
diff --git a/third_party/rust/flagset/Cargo.toml b/third_party/rust/flagset/Cargo.toml
new file mode 100644
index 0000000000..4164b7b932
--- /dev/null
+++ b/third_party/rust/flagset/Cargo.toml
@@ -0,0 +1,34 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "flagset"
+version = "0.4.3"
+authors = ["Nathaniel McCallum <nathaniel@profian.com>"]
+description = "Data types and a macro for generating enumeration-based bit flags"
+homepage = "https://github.com/enarx/flagset"
+documentation = "https://docs.rs/flagset"
+readme = "README.md"
+keywords = ["flags", "bitflags", "enum", "enumflags"]
+license = "Apache-2.0"
+repository = "https://github.com/enarx/flagset"
+[package.metadata.docs.rs]
+all-features = true
+[dependencies.serde]
+version = "1.0"
+features = ["serde_derive"]
+optional = true
+[dev-dependencies.serde_json]
+version = "1.0"
+
+[dev-dependencies.serde_repr]
+version = "0.1"