summaryrefslogtreecommitdiffstats
path: root/third_party/rust/metal/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
commit36d22d82aa202bb199967e9512281e9a53db42c9 (patch)
tree105e8c98ddea1c1e4784a60a5a6410fa416be2de /third_party/rust/metal/Makefile
parentInitial commit. (diff)
downloadfirefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.tar.xz
firefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.zip
Adding upstream version 115.7.0esr.upstream/115.7.0esr
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/metal/Makefile')
-rw-r--r--third_party/rust/metal/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/third_party/rust/metal/Makefile b/third_party/rust/metal/Makefile
new file mode 100644
index 0000000000..bc35876945
--- /dev/null
+++ b/third_party/rust/metal/Makefile
@@ -0,0 +1,12 @@
+
+compute:
+ xcrun -sdk macosx metal -c examples/compute/shaders.metal -o examples/compute/shaders.air
+ xcrun -sdk macosx metallib examples/compute/shaders.air -o examples/compute/shaders.metallib
+
+window:
+ xcrun -sdk macosx metal -c examples/window/shaders.metal -o examples/window/shaders.air
+ xcrun -sdk macosx metallib examples/window/shaders.air -o examples/window/shaders.metallib
+
+circle:
+ xcrun -sdk macosx metal -c examples/circle/shaders.metal -o examples/circle/shaders.air
+ xcrun -sdk macosx metallib examples/circle/shaders.air -o examples/circle/shaders.metallib