summaryrefslogtreecommitdiffstats
path: root/third_party/rust/naga/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
commit36d22d82aa202bb199967e9512281e9a53db42c9 (patch)
tree105e8c98ddea1c1e4784a60a5a6410fa416be2de /third_party/rust/naga/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.tar.xz
firefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.zip
Adding upstream version 115.7.0esr.upstream/115.7.0esr
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/naga/Cargo.toml')
-rw-r--r--third_party/rust/naga/Cargo.toml169
1 files changed, 169 insertions, 0 deletions
diff --git a/third_party/rust/naga/Cargo.toml b/third_party/rust/naga/Cargo.toml
new file mode 100644
index 0000000000..a5cf96609d
--- /dev/null
+++ b/third_party/rust/naga/Cargo.toml
@@ -0,0 +1,169 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+rust-version = "1.63"
+name = "naga"
+version = "0.12.0"
+authors = ["Naga Developers"]
+exclude = [
+ "bin/**/*",
+ "tests/**/*",
+ "Cargo.lock",
+ "target/**/*",
+]
+description = "Shader translation infrastructure"
+homepage = "https://github.com/gfx-rs/naga"
+readme = "README.md"
+keywords = [
+ "shader",
+ "SPIR-V",
+ "GLSL",
+ "MSL",
+]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/gfx-rs/naga"
+resolver = "2"
+
+[package.metadata.docs.rs]
+all-features = true
+
+[profile.dev]
+panic = "abort"
+
+[profile.release]
+panic = "abort"
+
+[[bench]]
+name = "criterion"
+harness = false
+
+[dependencies]
+bit-set = "0.5"
+bitflags = "1.0.5"
+log = "0.4"
+num-traits = "0.2"
+rustc-hash = "1.1.0"
+thiserror = "1.0.21"
+
+[dependencies.arbitrary]
+version = "1.0.2"
+features = ["derive"]
+optional = true
+
+[dependencies.codespan-reporting]
+version = "0.11.0"
+optional = true
+
+[dependencies.hexf-parse]
+version = "0.2.1"
+optional = true
+
+[dependencies.indexmap]
+version = "1.9.2"
+features = ["std"]
+
+[dependencies.petgraph]
+version = "0.6"
+optional = true
+
+[dependencies.pp-rs]
+version = "0.2.1"
+optional = true
+
+[dependencies.serde]
+version = "1.0.103"
+features = ["derive"]
+optional = true
+
+[dependencies.spirv]
+version = "0.2"
+optional = true
+
+[dependencies.termcolor]
+version = "1.0.4"
+optional = true
+
+[dependencies.unicode-xid]
+version = "0.2.3"
+optional = true
+
+[dev-dependencies]
+bincode = "1"
+diff = "0.1"
+env_logger = "0.9"
+ron = "~0.7.1"
+
+[dev-dependencies.criterion]
+version = "0.3"
+features = []
+
+[dev-dependencies.rspirv]
+version = "0.11"
+git = "https://github.com/gfx-rs/rspirv"
+rev = "b969f175d5663258b4891e44b76c1544da9661ab"
+
+[dev-dependencies.serde]
+version = "1.0"
+features = ["derive"]
+
+[dev-dependencies.spirv]
+version = "0.2"
+features = ["deserialize"]
+
+[features]
+arbitrary = [
+ "dep:arbitrary",
+ "indexmap/arbitrary",
+]
+clone = []
+default = []
+deserialize = [
+ "serde",
+ "indexmap/serde-1",
+]
+dot-out = []
+glsl-in = ["pp-rs"]
+glsl-out = []
+hlsl-out = []
+msl-out = []
+serialize = [
+ "serde",
+ "indexmap/serde-1",
+]
+span = [
+ "codespan-reporting",
+ "termcolor",
+]
+spv-in = [
+ "petgraph",
+ "spirv",
+]
+spv-out = ["spirv"]
+validate = []
+wgsl-in = [
+ "codespan-reporting",
+ "hexf-parse",
+ "termcolor",
+ "unicode-xid",
+]
+wgsl-out = []
+
+[workspace]
+members = [
+ ".",
+ "cli",
+]
+default-members = [
+ ".",
+ "cli",
+]