summaryrefslogtreecommitdiffstats
path: root/third_party/rust/os_str_bytes/Cargo.toml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
commit36d22d82aa202bb199967e9512281e9a53db42c9 (patch)
tree105e8c98ddea1c1e4784a60a5a6410fa416be2de /third_party/rust/os_str_bytes/Cargo.toml
parentInitial commit. (diff)
downloadfirefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.tar.xz
firefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.zip
Adding upstream version 115.7.0esr.upstream/115.7.0esr
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'third_party/rust/os_str_bytes/Cargo.toml')
-rw-r--r--third_party/rust/os_str_bytes/Cargo.toml78
1 files changed, 78 insertions, 0 deletions
diff --git a/third_party/rust/os_str_bytes/Cargo.toml b/third_party/rust/os_str_bytes/Cargo.toml
new file mode 100644
index 0000000000..e33d3d4961
--- /dev/null
+++ b/third_party/rust/os_str_bytes/Cargo.toml
@@ -0,0 +1,78 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+rust-version = "1.57.0"
+name = "os_str_bytes"
+version = "6.4.1"
+authors = ["dylni"]
+exclude = [
+ ".*",
+ "tests.rs",
+ "/rustfmt.toml",
+ "/src/bin",
+ "/tests",
+]
+description = """
+Convert between byte sequences and platform-native strings
+"""
+readme = "README.md"
+keywords = [
+ "bytes",
+ "osstr",
+ "osstring",
+ "path",
+ "windows",
+]
+categories = [
+ "command-line-interface",
+ "development-tools::ffi",
+ "encoding",
+ "os",
+ "rust-patterns",
+]
+license = "MIT OR Apache-2.0"
+repository = "https://github.com/dylni/os_str_bytes"
+
+[package.metadata.docs.rs]
+all-features = true
+rustc-args = [
+ "--cfg",
+ "os_str_bytes_docs_rs",
+]
+rustdoc-args = [
+ "--cfg",
+ "os_str_bytes_docs_rs",
+]
+
+[dependencies.memchr]
+version = "2.4"
+optional = true
+
+[dependencies.print_bytes]
+version = "0.7"
+optional = true
+
+[dependencies.uniquote]
+version = "3.0"
+optional = true
+
+[dev-dependencies.getrandom]
+version = "0.2"
+
+[features]
+checked_conversions = []
+default = [
+ "memchr",
+ "raw_os_str",
+]
+raw_os_str = []