summaryrefslogtreecommitdiffstats
path: root/toolkit/components/commandlines/test/unit_unix
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
commit36d22d82aa202bb199967e9512281e9a53db42c9 (patch)
tree105e8c98ddea1c1e4784a60a5a6410fa416be2de /toolkit/components/commandlines/test/unit_unix
parentInitial commit. (diff)
downloadfirefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.tar.xz
firefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.zip
Adding upstream version 115.7.0esr.upstream/115.7.0esr
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'toolkit/components/commandlines/test/unit_unix')
-rw-r--r--toolkit/components/commandlines/test/unit_unix/test_bug410156.js14
-rw-r--r--toolkit/components/commandlines/test/unit_unix/xpcshell.ini8
2 files changed, 22 insertions, 0 deletions
diff --git a/toolkit/components/commandlines/test/unit_unix/test_bug410156.js b/toolkit/components/commandlines/test/unit_unix/test_bug410156.js
new file mode 100644
index 0000000000..71c45b8638
--- /dev/null
+++ b/toolkit/components/commandlines/test/unit_unix/test_bug410156.js
@@ -0,0 +1,14 @@
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this
+ * file, You can obtain one at http://mozilla.org/MPL/2.0/. */
+
+function run_test() {
+ var commandLine = Cu.createCommandLine(
+ [],
+ null,
+ Ci.nsICommandLine.STATE_INITIAL_LAUNCH
+ );
+ var urlFile = do_get_file("../unit/data/test_bug410156.desktop");
+ var uri = commandLine.resolveURI(urlFile.path);
+ Assert.equal(uri.spec, "http://www.bug410156.com/");
+}
diff --git a/toolkit/components/commandlines/test/unit_unix/xpcshell.ini b/toolkit/components/commandlines/test/unit_unix/xpcshell.ini
new file mode 100644
index 0000000000..f17374f14a
--- /dev/null
+++ b/toolkit/components/commandlines/test/unit_unix/xpcshell.ini
@@ -0,0 +1,8 @@
+[DEFAULT]
+head =
+skip-if = toolkit == 'android'
+support-files =
+ !/toolkit/components/commandlines/test/unit/data/test_bug410156.desktop
+ !/toolkit/components/commandlines/test/unit/data/test_bug410156.url
+
+[test_bug410156.js]