summaryrefslogtreecommitdiffstats
path: root/toolkit/components/reader/ReaderWorker.js
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
commit36d22d82aa202bb199967e9512281e9a53db42c9 (patch)
tree105e8c98ddea1c1e4784a60a5a6410fa416be2de /toolkit/components/reader/ReaderWorker.js
parentInitial commit. (diff)
downloadfirefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.tar.xz
firefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.zip
Adding upstream version 115.7.0esr.upstream/115.7.0esr
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'toolkit/components/reader/ReaderWorker.js')
-rw-r--r--toolkit/components/reader/ReaderWorker.js61
1 files changed, 61 insertions, 0 deletions
diff --git a/toolkit/components/reader/ReaderWorker.js b/toolkit/components/reader/ReaderWorker.js
new file mode 100644
index 0000000000..f604707ba9
--- /dev/null
+++ b/toolkit/components/reader/ReaderWorker.js
@@ -0,0 +1,61 @@
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this file,
+ * You can obtain one at http://mozilla.org/MPL/2.0/. */
+
+/* eslint-env mozilla/chrome-worker */
+
+"use strict";
+
+/**
+ * A worker dedicated to handle parsing documents for reader view.
+ */
+
+/* import-globals-from /toolkit/components/workerloader/require.js */
+/* global JSDOMParser */
+/* import-globals-from /toolkit/components/reader/Readability.js */
+importScripts(
+ "resource://gre/modules/workers/require.js",
+ "resource://gre/modules/reader/JSDOMParser.js",
+ "resource://gre/modules/reader/Readability.js"
+);
+
+var PromiseWorker = require("resource://gre/modules/workers/PromiseWorker.js");
+
+const DEBUG = false;
+
+var worker = new PromiseWorker.AbstractWorker();
+worker.dispatch = function (method, args = []) {
+ return Agent[method](...args);
+};
+worker.postMessage = function (result, ...transfers) {
+ self.postMessage(result, ...transfers);
+};
+worker.close = function () {
+ self.close();
+};
+worker.log = function (...args) {
+ if (DEBUG) {
+ dump("ReaderWorker: " + args.join(" ") + "\n");
+ }
+};
+
+self.addEventListener("message", msg => worker.handleMessage(msg));
+self.addEventListener("unhandledrejection", function (error) {
+ throw error.reason;
+});
+
+var Agent = {
+ /**
+ * Parses structured article data from a document.
+ *
+ * @param {object} uri URI data for the document.
+ * @param {string} serializedDoc The serialized document.
+ * @param {object} options Options object to pass to Readability.
+ *
+ * @return {object} Article object returned from Readability.
+ */
+ parseDocument(uri, serializedDoc, options) {
+ let doc = new JSDOMParser().parse(serializedDoc, uri.spec);
+ return new Readability(doc, options).parse();
+ },
+};