summaryrefslogtreecommitdiffstats
path: root/toolkit/components/uniffi-fixture-external-types
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
commit36d22d82aa202bb199967e9512281e9a53db42c9 (patch)
tree105e8c98ddea1c1e4784a60a5a6410fa416be2de /toolkit/components/uniffi-fixture-external-types
parentInitial commit. (diff)
downloadfirefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.tar.xz
firefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.zip
Adding upstream version 115.7.0esr.upstream/115.7.0esr
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'toolkit/components/uniffi-fixture-external-types')
-rw-r--r--toolkit/components/uniffi-fixture-external-types/Cargo.toml15
-rw-r--r--toolkit/components/uniffi-fixture-external-types/build.rs7
-rw-r--r--toolkit/components/uniffi-fixture-external-types/src/external-types.udl10
-rw-r--r--toolkit/components/uniffi-fixture-external-types/src/lib.rs12
4 files changed, 44 insertions, 0 deletions
diff --git a/toolkit/components/uniffi-fixture-external-types/Cargo.toml b/toolkit/components/uniffi-fixture-external-types/Cargo.toml
new file mode 100644
index 0000000000..6cfd390ff3
--- /dev/null
+++ b/toolkit/components/uniffi-fixture-external-types/Cargo.toml
@@ -0,0 +1,15 @@
+[package]
+name = "uniffi-fixture-external-types"
+edition = "2021"
+version = "0.21.0"
+authors = ["Firefox Sync Team <sync-team@mozilla.com>"]
+license = "MPL-2.0"
+publish = false
+
+[dependencies]
+uniffi-example-geometry = { git = "https://github.com/mozilla/uniffi-rs.git", rev = "bc7ff8977bf38d0fdd1a458810b14f434d4dc4de" }
+uniffi = { workspace = true }
+thiserror = "1.0"
+
+[build-dependencies]
+uniffi = { workspace = true, features = ["build"] }
diff --git a/toolkit/components/uniffi-fixture-external-types/build.rs b/toolkit/components/uniffi-fixture-external-types/build.rs
new file mode 100644
index 0000000000..13f56ca56b
--- /dev/null
+++ b/toolkit/components/uniffi-fixture-external-types/build.rs
@@ -0,0 +1,7 @@
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this
+ * file, You can obtain one at http://mozilla.org/MPL/2.0/. */
+
+fn main() {
+ uniffi::generate_scaffolding("./src/external-types.udl").unwrap();
+}
diff --git a/toolkit/components/uniffi-fixture-external-types/src/external-types.udl b/toolkit/components/uniffi-fixture-external-types/src/external-types.udl
new file mode 100644
index 0000000000..a0cdaae52d
--- /dev/null
+++ b/toolkit/components/uniffi-fixture-external-types/src/external-types.udl
@@ -0,0 +1,10 @@
+// A type defined in the `geometry` component
+[External="uniffi_geometry"]
+typedef extern Point;
+
+[External="uniffi_geometry"]
+typedef extern Line;
+
+namespace external_types {
+ double gradient(Line? value);
+};
diff --git a/toolkit/components/uniffi-fixture-external-types/src/lib.rs b/toolkit/components/uniffi-fixture-external-types/src/lib.rs
new file mode 100644
index 0000000000..896c5d4c53
--- /dev/null
+++ b/toolkit/components/uniffi-fixture-external-types/src/lib.rs
@@ -0,0 +1,12 @@
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this
+ * file, You can obtain one at http://mozilla.org/MPL/2.0/. */
+
+pub fn gradient(value: Option<uniffi_geometry::Line>) -> f64 {
+ match value {
+ None => 0.0,
+ Some(value) => uniffi_geometry::gradient(value),
+ }
+}
+
+include!(concat!(env!("OUT_DIR"), "/external-types.uniffi.rs"));