summaryrefslogtreecommitdiffstats
path: root/toolkit/library/build/Makefile.in
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-04-07 19:33:14 +0000
commit36d22d82aa202bb199967e9512281e9a53db42c9 (patch)
tree105e8c98ddea1c1e4784a60a5a6410fa416be2de /toolkit/library/build/Makefile.in
parentInitial commit. (diff)
downloadfirefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.tar.xz
firefox-esr-36d22d82aa202bb199967e9512281e9a53db42c9.zip
Adding upstream version 115.7.0esr.upstream/115.7.0esr
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'toolkit/library/build/Makefile.in')
-rw-r--r--toolkit/library/build/Makefile.in20
1 files changed, 20 insertions, 0 deletions
diff --git a/toolkit/library/build/Makefile.in b/toolkit/library/build/Makefile.in
new file mode 100644
index 0000000000..474c42518c
--- /dev/null
+++ b/toolkit/library/build/Makefile.in
@@ -0,0 +1,20 @@
+# This Source Code Form is subject to the terms of the Mozilla Public
+# License, v. 2.0. If a copy of the MPL was not distributed with this file,
+# You can obtain one at http://mozilla.org/MPL/2.0/.
+
+include $(topsrcdir)/config/config.mk
+
+include $(topsrcdir)/config/rules.mk
+
+DUMP_SYMBOLS_FLAGS = --count-ctors
+
+ifdef CLANG_CL
+ifdef MOZ_PROFILE_USE
+ifeq (x86,$(CPU_ARCH))
+PGO_LDFLAGS += -ORDER:@$(topsrcdir)/build/win32/orderfile.txt
+endif
+ifeq (x86_64,$(CPU_ARCH))
+PGO_LDFLAGS += -ORDER:@$(topsrcdir)/build/win64/orderfile.txt
+endif
+endif
+endif