summaryrefslogtreecommitdiffstats
path: root/devtools/startup/tests/browser
diff options
context:
space:
mode:
Diffstat (limited to 'devtools/startup/tests/browser')
-rw-r--r--devtools/startup/tests/browser/browser.ini9
-rw-r--r--devtools/startup/tests/browser/browser_command_line_urls.js159
-rw-r--r--devtools/startup/tests/browser/browser_shim_disable_devtools.js165
-rw-r--r--devtools/startup/tests/browser/command-line.html10
-rw-r--r--devtools/startup/tests/browser/command-line.js3
5 files changed, 346 insertions, 0 deletions
diff --git a/devtools/startup/tests/browser/browser.ini b/devtools/startup/tests/browser/browser.ini
new file mode 100644
index 0000000000..ff47eceb76
--- /dev/null
+++ b/devtools/startup/tests/browser/browser.ini
@@ -0,0 +1,9 @@
+[DEFAULT]
+tags = devtools
+subsuite = devtools
+support-files=
+ command-line.html
+ command-line.js
+
+[browser_shim_disable_devtools.js]
+[browser_command_line_urls.js]
diff --git a/devtools/startup/tests/browser/browser_command_line_urls.js b/devtools/startup/tests/browser/browser_command_line_urls.js
new file mode 100644
index 0000000000..e435d08406
--- /dev/null
+++ b/devtools/startup/tests/browser/browser_command_line_urls.js
@@ -0,0 +1,159 @@
+/* Any copyright is dedicated to the Public Domain.
+ http://creativecommons.org/publicdomain/zero/1.0/ */
+
+"use strict";
+
+/**
+ * Test command line processing of URLs meant to be intepreted by DevTools.
+ */
+
+/* eslint-env browser */
+
+const { DevToolsStartup } = ChromeUtils.importESModule(
+ "resource:///modules/DevToolsStartup.sys.mjs"
+);
+
+const { require } = ChromeUtils.importESModule(
+ "resource://devtools/shared/loader/Loader.sys.mjs"
+);
+const { gDevTools } = require("devtools/client/framework/devtools");
+
+const URL_ROOT = "https://example.org/browser/devtools/startup/tests/browser/";
+
+const startup = new DevToolsStartup();
+// The feature covered here only work when calling firefox from command line
+// while it is already opened. So fake Firefox being already opened:
+startup.initialized = true;
+
+add_task(async function ignoredUrls() {
+ const tabCount = gBrowser.tabs.length;
+
+ // We explicitely try to ignore these URL which looks like line, but are passwords
+ sendUrlViaCommandLine("https://foo@user:123");
+ sendUrlViaCommandLine("https://foo@user:123");
+ sendUrlViaCommandLine("https://foo@123:456");
+
+ // The following is an invalid URL (domain with space)
+ sendUrlViaCommandLine("https://foo /index.html:123:456");
+
+ // eslint-disable-next-line mozilla/no-arbitrary-setTimeout
+ await new Promise(r => setTimeout(r, 1000));
+
+ is(tabCount, gBrowser.tabs.length);
+});
+
+/**
+ * With DevTools closed, but DevToolsStartup "initialized",
+ * the url will be opened via view-source
+ */
+add_task(async function openingWithDevToolsClosed() {
+ const url = URL_ROOT + "command-line.html:5:2";
+
+ const newTabOpened = BrowserTestUtils.waitForNewTab(gBrowser);
+ sendUrlViaCommandLine(url);
+ const newTab = await newTabOpened;
+ is(
+ newTab.linkedBrowser.documentURI.spec,
+ "view-source:" + URL_ROOT + "command-line.html"
+ );
+
+ await SpecialPowers.spawn(gBrowser.selectedBrowser, [], async function () {
+ const selection = content.getSelection();
+ Assert.equal(
+ selection.toString(),
+ " <title>Command line test page</title>",
+ "The 5th line is selected in view-source"
+ );
+ });
+ await gBrowser.removeTab(newTab);
+});
+
+/**
+ * With DevTools opened, but the source isn't in the debugged tab,
+ * the url will also be opened via view-source
+ */
+add_task(async function openingWithDevToolsButUnknownSource() {
+ const url = URL_ROOT + "command-line.html:5:2";
+
+ const tab = BrowserTestUtils.addTab(
+ gBrowser,
+ "data:text/html;charset=utf-8,<title>foo</title>"
+ );
+
+ const toolbox = await gDevTools.showToolboxForTab(gBrowser.selectedTab, {
+ toolId: "jsdebugger",
+ });
+
+ const newTabOpened = BrowserTestUtils.waitForNewTab(gBrowser);
+ sendUrlViaCommandLine(url);
+ const newTab = await newTabOpened;
+ is(
+ newTab.linkedBrowser.documentURI.spec,
+ "view-source:" + URL_ROOT + "command-line.html"
+ );
+
+ await SpecialPowers.spawn(gBrowser.selectedBrowser, [], async function () {
+ const selection = content.getSelection();
+ Assert.equal(
+ selection.toString(),
+ " <title>Command line test page</title>",
+ "The 5th line is selected in view-source"
+ );
+ });
+ await gBrowser.removeTab(newTab);
+
+ await toolbox.destroy();
+ await gBrowser.removeTab(tab);
+});
+
+/**
+ * With DevTools opened, and the source is debugged by the debugger,
+ * the url will be opened in the debugger.
+ */
+add_task(async function openingWithDevToolsAndKnownSource() {
+ const url = URL_ROOT + "command-line.js:5:2";
+
+ const tab = await BrowserTestUtils.openNewForegroundTab(
+ gBrowser,
+ URL_ROOT + "command-line.html"
+ );
+ const toolbox = await gDevTools.showToolboxForTab(tab, {
+ toolId: "jsdebugger",
+ });
+
+ info("Open a first URL with line and column");
+ sendUrlViaCommandLine(url);
+
+ const dbg = toolbox.getPanel("jsdebugger");
+ const selectedLocation = await BrowserTestUtils.waitForCondition(() => {
+ return dbg._selectors.getSelectedLocation(dbg._getState());
+ });
+ is(selectedLocation.source.url, URL_ROOT + "command-line.js");
+ is(selectedLocation.line, 5);
+ is(selectedLocation.column, 2);
+
+ info("Open another URL with only a line");
+ const url2 = URL_ROOT + "command-line.js:6";
+ sendUrlViaCommandLine(url2);
+ const selectedLocation2 = await BrowserTestUtils.waitForCondition(() => {
+ const location = dbg._selectors.getSelectedLocation(dbg._getState());
+ return location.line == 6 ? location : false;
+ });
+ is(selectedLocation2.source.url, URL_ROOT + "command-line.js");
+ is(selectedLocation2.line, 6);
+ is(selectedLocation2.column, 0);
+
+ await toolbox.destroy();
+ await gBrowser.removeTab(tab);
+});
+
+// Fake opening an existing firefox instance with a URL
+// passed via `-url` command line argument
+function sendUrlViaCommandLine(url) {
+ const cmdLine = Cu.createCommandLine(
+ ["-url", url],
+ null,
+ Ci.nsICommandLine.STATE_REMOTE_EXPLICIT
+ );
+ startup.handle(cmdLine);
+}
diff --git a/devtools/startup/tests/browser/browser_shim_disable_devtools.js b/devtools/startup/tests/browser/browser_shim_disable_devtools.js
new file mode 100644
index 0000000000..1a16902099
--- /dev/null
+++ b/devtools/startup/tests/browser/browser_shim_disable_devtools.js
@@ -0,0 +1,165 @@
+/* Any copyright is dedicated to the Public Domain.
+ http://creativecommons.org/publicdomain/zero/1.0/ */
+
+"use strict";
+
+/* eslint-env browser */
+
+const { require } = ChromeUtils.importESModule(
+ "resource://devtools/shared/loader/Loader.sys.mjs"
+);
+
+const { gDevTools } = require("devtools/client/framework/devtools");
+
+async function simulateMenuOpen(menu) {
+ return new Promise(resolve => {
+ menu.addEventListener("popupshown", resolve, { once: true });
+ menu.dispatchEvent(new MouseEvent("popupshowing"));
+ menu.dispatchEvent(new MouseEvent("popupshown"));
+ });
+}
+
+async function simulateMenuClosed(menu) {
+ return new Promise(resolve => {
+ menu.addEventListener("popuphidden", resolve, { once: true });
+ menu.dispatchEvent(new MouseEvent("popuphiding"));
+ menu.dispatchEvent(new MouseEvent("popuphidden"));
+ });
+}
+
+/**
+ * Test that the preference devtools.policy.disabled disables entry points for devtools.
+ */
+add_task(async function () {
+ info(
+ "Disable DevTools entry points (does not apply to the already created window"
+ );
+ await new Promise(resolve => {
+ const options = { set: [["devtools.policy.disabled", true]] };
+ SpecialPowers.pushPrefEnv(options, resolve);
+ });
+
+ // In DEV_EDITION the browser starts with the developer-button in the toolbar. This
+ // applies to all new windows and forces creating keyboard shortcuts. The preference
+ // tested should not change without restart, but for the needs of the test, remove the
+ // developer-button from the UI before opening a new window.
+ if (AppConstants.MOZ_DEV_EDITION) {
+ CustomizableUI.removeWidgetFromArea("developer-button");
+ }
+
+ info(
+ "Open a new window, all window-specific hooks for DevTools will be disabled."
+ );
+ const win = OpenBrowserWindow({ private: false });
+ await waitForDelayedStartupFinished(win);
+
+ info(
+ "Open a new tab on the new window to ensure the focus is on the new window"
+ );
+ const tab = BrowserTestUtils.addTab(
+ win.gBrowser,
+ "data:text/html;charset=utf-8,<title>foo</title>"
+ );
+ await BrowserTestUtils.browserLoaded(win.gBrowser.getBrowserForTab(tab));
+
+ info(
+ "Synthesize a DevTools shortcut, the toolbox should not open on this new window."
+ );
+ synthesizeToggleToolboxKey(win);
+
+ // There is no event to wait for here as this shortcut should have no effect.
+ /* eslint-disable mozilla/no-arbitrary-setTimeout */
+ await new Promise(r => setTimeout(r, 1000));
+
+ is(gDevTools._toolboxesPerCommands.size, 0, "No toolbox has been opened");
+
+ info("Open the context menu for the content page.");
+ const contextMenu = win.document.getElementById("contentAreaContextMenu");
+ const popupShownPromise = BrowserTestUtils.waitForEvent(
+ contextMenu,
+ "popupshown"
+ );
+ EventUtils.synthesizeMouseAtCenter(
+ win.document.documentElement,
+ { type: "contextmenu", button: 2 },
+ win
+ );
+ await popupShownPromise;
+
+ const inspectElementItem = contextMenu.querySelector(`#context-inspect`);
+ ok(
+ inspectElementItem.hidden,
+ "The inspect element item is hidden in the context menu"
+ );
+
+ info("Close the context menu");
+ const onContextMenuHidden = BrowserTestUtils.waitForEvent(
+ contextMenu,
+ "popuphidden"
+ );
+ contextMenu.hidePopup();
+ await onContextMenuHidden;
+
+ info("Open the menubar Tools menu");
+ const toolsMenuPopup = win.document.getElementById("menu_ToolsPopup");
+ const browserToolsMenu = win.document.getElementById("browserToolsMenu");
+ ok(
+ !browserToolsMenu.hidden,
+ "The Browser Tools item of the tools menu is visible"
+ );
+
+ await simulateMenuOpen(toolsMenuPopup);
+ const subMenu = win.document.getElementById("menuWebDeveloperPopup");
+
+ info("Open the Browser Tools sub-menu");
+ await simulateMenuOpen(subMenu);
+
+ const visibleMenuItems = Array.from(
+ subMenu.querySelectorAll("menuitem")
+ ).filter(item => !item.hidden);
+
+ const { menuitems } = require("devtools/client/menus");
+ for (const devtoolsItem of menuitems) {
+ ok(
+ !visibleMenuItems.some(item => item.id === devtoolsItem.id),
+ "DevTools menu item is not visible in the Browser Tools menu"
+ );
+ }
+
+ info("Close out the menu popups");
+ await simulateMenuClosed(subMenu);
+ await simulateMenuClosed(toolsMenuPopup);
+
+ win.gBrowser.removeTab(tab);
+
+ info("Close the test window");
+ const winClosed = BrowserTestUtils.windowClosed(win);
+ win.BrowserTryToCloseWindow();
+ await winClosed;
+});
+
+function waitForDelayedStartupFinished(win) {
+ return new Promise(resolve => {
+ Services.obs.addObserver(function observer(subject, topic) {
+ if (win == subject) {
+ Services.obs.removeObserver(
+ observer,
+ "browser-delayed-startup-finished"
+ );
+ resolve();
+ }
+ }, "browser-delayed-startup-finished");
+ });
+}
+
+/**
+ * Helper to call the toggle devtools shortcut.
+ */
+function synthesizeToggleToolboxKey(win) {
+ info("Trigger the toogle toolbox shortcut");
+ if (Services.appinfo.OS == "Darwin") {
+ EventUtils.synthesizeKey("i", { accelKey: true, altKey: true }, win);
+ } else {
+ EventUtils.synthesizeKey("i", { accelKey: true, shiftKey: true }, win);
+ }
+}
diff --git a/devtools/startup/tests/browser/command-line.html b/devtools/startup/tests/browser/command-line.html
new file mode 100644
index 0000000000..c8f14b95bd
--- /dev/null
+++ b/devtools/startup/tests/browser/command-line.html
@@ -0,0 +1,10 @@
+<!DOCTYPE html>
+<html>
+<head>
+ <meta charset="UTF-8">
+ <title>Command line test page</title>
+</head>
+<body>
+ <script src="command-line.js"></script>
+</body>
+</html>
diff --git a/devtools/startup/tests/browser/command-line.js b/devtools/startup/tests/browser/command-line.js
new file mode 100644
index 0000000000..c15c83407b
--- /dev/null
+++ b/devtools/startup/tests/browser/command-line.js
@@ -0,0 +1,3 @@
+"use strict";
+
+console.log("command line script");