summaryrefslogtreecommitdiffstats
path: root/gfx/wr/wrench/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'gfx/wr/wrench/Cargo.toml')
-rw-r--r--gfx/wr/wrench/Cargo.toml76
1 files changed, 76 insertions, 0 deletions
diff --git a/gfx/wr/wrench/Cargo.toml b/gfx/wr/wrench/Cargo.toml
new file mode 100644
index 0000000000..1c434b7894
--- /dev/null
+++ b/gfx/wr/wrench/Cargo.toml
@@ -0,0 +1,76 @@
+[package]
+name = "wrench"
+version = "0.3.0"
+authors = ["Vladimir Vukicevic <vladimir@pobox.com>"]
+build = "build.rs"
+license = "MPL-2.0"
+edition = "2018"
+
+# Required by cargo-apk to build for Android
+[lib]
+crate-type = ["lib", "cdylib"]
+path = "src/main.rs"
+
+[dependencies]
+base64 = "0.13"
+env_logger = { version = "0.10", optional = true, default_features = false }
+gleam = "0.15"
+glutin = "0.28"
+clap = { version = "3.1", features = ["yaml"] }
+glsl-lang = { version = "0.2", features = ["lexer-v2-full"] }
+log = "0.4"
+yaml-rust = "0.4"
+serde_json = "1.0"
+time = "0.1"
+chrono = "0.4"
+crossbeam = "0.2"
+osmesa-sys = { version = "0.1.2", optional = true }
+osmesa-src = { version = "0.2", git = "https://github.com/servo/osmesa-src", optional = true }
+webrender = { path = "../webrender", features = ["capture", "replay", "png", "profiler", "dynamic_freetype", "leak_checks"] }
+webrender_build = { path = "../webrender_build" }
+winit = "0.26"
+serde = { version = "1.0", features = ["derive"] }
+semver = "1.0.12"
+swgl = { path = "../swgl", optional = true }
+tracy-rs = "0.1.2"
+
+[dependencies.image]
+version = "0.23"
+default-features = false
+features = ["png"]
+
+[target.'cfg(target_os = "macos")'.dependencies]
+core-graphics = "0.22"
+core-foundation = "0.9"
+
+[features]
+default = [ "env_logger" ]
+headless = [ "osmesa-sys", "osmesa-src" ]
+software = [ "swgl" ]
+
+[target.'cfg(target_os = "windows")'.dependencies]
+dwrote = "0.11"
+mozangle = { version = "0.3.2", features = ["egl"] }
+
+[target.'cfg(target_os = "android")'.dependencies]
+libc = "0.2"
+ndk-glue = "0.5"
+
+[target.'cfg(all(unix, not(target_os = "android")))'.dependencies]
+font-loader = "0.11"
+
+# Configuration information used when building wrench as an APK.
+[package.metadata.android]
+package = "org.mozilla.wrench"
+build_targets = [ "armv7-linux-androideabi", "i686-linux-android" ]
+opengles_version_major = 3
+opengles_version_minor = 0
+
+[package.metadata.android.sdk]
+# keep it in sync with android-sdk-version in android-sdk.configure
+target_sdk_version = 33
+min_sdk_version = 18
+
+[package.metadata.android.application]
+label = "Wrench"
+debuggable = true