summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/css/css-sizing/aspect-ratio/flex-aspect-ratio-028.html
diff options
context:
space:
mode:
Diffstat (limited to 'testing/web-platform/tests/css/css-sizing/aspect-ratio/flex-aspect-ratio-028.html')
-rw-r--r--testing/web-platform/tests/css/css-sizing/aspect-ratio/flex-aspect-ratio-028.html24
1 files changed, 24 insertions, 0 deletions
diff --git a/testing/web-platform/tests/css/css-sizing/aspect-ratio/flex-aspect-ratio-028.html b/testing/web-platform/tests/css/css-sizing/aspect-ratio/flex-aspect-ratio-028.html
new file mode 100644
index 0000000000..1819d30cdd
--- /dev/null
+++ b/testing/web-platform/tests/css/css-sizing/aspect-ratio/flex-aspect-ratio-028.html
@@ -0,0 +1,24 @@
+<!DOCTYPE html>
+<title>CSS aspect-ratio: auto size img with attributes width and height inside column flexbox</title>
+<link rel="help" href="https://html.spec.whatwg.org/#map-to-the-aspect-ratio-property-(using-dimension-rules)">
+<link rel="help" href="https://www.w3.org/TR/css-flexbox-1/#layout-algorithm">
+<link rel="match" href="../../reference/ref-filled-green-100px-square.xht" />
+
+<p>Test passes if there is a filled green square and <strong>no red</strong>.</p>
+<style>
+ div {
+ width: 100px;
+ display: flex;
+ flex-direction: column;
+ }
+ img {
+ width: auto;
+ height: auto;
+ }
+</style>
+</head>
+
+<body>
+ <div><img width="200" height="200" src="support/200x200-green.png" /></div>
+</body>
+</html>