summaryrefslogtreecommitdiffstats
path: root/testing/web-platform/tests/encoding/legacy-mb-tchinese/big5/big5-decode.html
diff options
context:
space:
mode:
Diffstat (limited to 'testing/web-platform/tests/encoding/legacy-mb-tchinese/big5/big5-decode.html')
-rw-r--r--testing/web-platform/tests/encoding/legacy-mb-tchinese/big5/big5-decode.html44
1 files changed, 44 insertions, 0 deletions
diff --git a/testing/web-platform/tests/encoding/legacy-mb-tchinese/big5/big5-decode.html b/testing/web-platform/tests/encoding/legacy-mb-tchinese/big5/big5-decode.html
new file mode 100644
index 0000000000..229abd8d9c
--- /dev/null
+++ b/testing/web-platform/tests/encoding/legacy-mb-tchinese/big5/big5-decode.html
@@ -0,0 +1,44 @@
+<!DOCTYPE html>
+<html lang="en-GB">
+<head>
+<meta charset="utf-8"/>
+<title>Big5 decoding</title>
+<meta name="timeout" content="long">
+<meta name="variant" content="?1-1000">
+<meta name="variant" content="?1001-2000">
+<meta name="variant" content="?2001-3000">
+<meta name="variant" content="?3001-4000">
+<meta name="variant" content="?4001-5000">
+<meta name="variant" content="?5001-6000">
+<meta name="variant" content="?6001-7000">
+<meta name="variant" content="?7001-8000">
+<meta name="variant" content="?8001-9000">
+<meta name="variant" content="?9001-10000">
+<meta name="variant" content="?10001-11000">
+<meta name="variant" content="?11001-12000">
+<meta name="variant" content="?12001-13000">
+<meta name="variant" content="?13001-14000">
+<meta name="variant" content="?14001-last">
+<script src="/resources/testharness.js"></script>
+<script src="/resources/testharnessreport.js"></script>
+<script src="/common/subset-tests.js"></script>
+<link rel="author" title="Richard Ishida" href="mailto:ishida@w3.org">
+<link rel="help" href="https://encoding.spec.whatwg.org/#big5">
+<meta name="assert" content="The browser decodes all characters as expected from a file generated by encoding all pointers in the big5 encoding per the encoder steps in the specification.">
+<style>
+ iframe { display:none }
+ form { display:none }
+</style>
+<script src="big5_index.js"></script>
+<script src="big5-decoder.js"></script>
+<script src="../../resources/decode-common.js"></script>
+</head>
+
+<body onload="showNodes(big5Decoder);">
+
+<iframe src="big5_chars.html" name="scriptWindow" id="scrwin"></iframe>
+
+<div id="log"></div>
+
+</body>
+</html>