summaryrefslogtreecommitdiffstats
path: root/third_party/rust/cssparser/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/cssparser/Cargo.toml')
-rw-r--r--third_party/rust/cssparser/Cargo.toml75
1 files changed, 75 insertions, 0 deletions
diff --git a/third_party/rust/cssparser/Cargo.toml b/third_party/rust/cssparser/Cargo.toml
new file mode 100644
index 0000000000..eeef7565b8
--- /dev/null
+++ b/third_party/rust/cssparser/Cargo.toml
@@ -0,0 +1,75 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+rust-version = "1.63"
+name = "cssparser"
+version = "0.31.0"
+authors = ["Simon Sapin <simon.sapin@exyr.org>"]
+exclude = [
+ "src/css-parsing-tests/**",
+ "src/big-data-url.css",
+]
+description = "Rust implementation of CSS Syntax Level 3"
+documentation = "https://docs.rs/cssparser/"
+readme = "README.md"
+keywords = [
+ "css",
+ "syntax",
+ "parser",
+]
+license = "MPL-2.0"
+repository = "https://github.com/servo/rust-cssparser"
+
+[dependencies]
+dtoa-short = "0.3"
+itoa = "1.0"
+smallvec = "1.0"
+
+[dependencies.cssparser-macros]
+version = "0.6"
+
+[dependencies.phf]
+version = ">=0.8,<=0.11"
+features = ["macros"]
+
+[dependencies.serde]
+version = "1.0"
+optional = true
+
+[dev-dependencies]
+difference = "2.0"
+encoding_rs = "0.8"
+serde_json = "1.0"
+
+[build-dependencies]
+proc-macro2 = "1"
+quote = "1"
+
+[build-dependencies.syn]
+version = "1"
+features = [
+ "extra-traits",
+ "fold",
+ "full",
+]
+
+[features]
+bench = []
+dummy_match_byte = []
+
+[workspace]
+members = [
+ ".",
+ "./macros",
+ "./procedural-masquerade",
+]