summaryrefslogtreecommitdiffstats
path: root/third_party/rust/phf_macros/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/phf_macros/Cargo.toml')
-rw-r--r--third_party/rust/phf_macros/Cargo.toml61
1 files changed, 61 insertions, 0 deletions
diff --git a/third_party/rust/phf_macros/Cargo.toml b/third_party/rust/phf_macros/Cargo.toml
new file mode 100644
index 0000000000..ccc1ce51fa
--- /dev/null
+++ b/third_party/rust/phf_macros/Cargo.toml
@@ -0,0 +1,61 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2018"
+name = "phf_macros"
+version = "0.10.0"
+authors = ["Steven Fackler <sfackler@gmail.com>"]
+include = ["src/lib.rs"]
+description = "Macros to generate types in the phf crate"
+readme = "../README.md"
+license = "MIT"
+repository = "https://github.com/sfackler/rust-phf"
+
+[lib]
+proc-macro = true
+[dependencies.phf_generator]
+version = "0.10.0"
+
+[dependencies.phf_shared]
+version = "0.10.0"
+default-features = false
+
+[dependencies.proc-macro-hack]
+version = "0.5.4"
+
+[dependencies.proc-macro2]
+version = "1"
+
+[dependencies.quote]
+version = "1"
+
+[dependencies.syn]
+version = "1"
+features = ["full"]
+
+[dependencies.unicase_]
+version = "2.4.0"
+optional = true
+package = "unicase"
+[dev-dependencies.phf]
+version = "0.9"
+features = ["macros", "unicase"]
+
+[dev-dependencies.trybuild]
+version = "1.0"
+
+[dev-dependencies.unicase_]
+version = "2.4.0"
+package = "unicase"
+
+[features]
+unicase = ["unicase_", "phf_shared/unicase"]