summaryrefslogtreecommitdiffstats
path: root/third_party/rust/prost-derive/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/prost-derive/Cargo.toml')
-rw-r--r--third_party/rust/prost-derive/Cargo.toml40
1 files changed, 40 insertions, 0 deletions
diff --git a/third_party/rust/prost-derive/Cargo.toml b/third_party/rust/prost-derive/Cargo.toml
new file mode 100644
index 0000000000..d6c2d3e74c
--- /dev/null
+++ b/third_party/rust/prost-derive/Cargo.toml
@@ -0,0 +1,40 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies
+#
+# If you believe there's an error in this file please file an
+# issue against the rust-lang/cargo repository. If you're
+# editing this file be aware that the upstream Cargo.toml
+# will likely look very different (and much more reasonable)
+
+[package]
+edition = "2018"
+name = "prost-derive"
+version = "0.8.0"
+authors = ["Dan Burkert <dan@danburkert.com>", "Tokio Contributors <team@tokio.rs>"]
+description = "A Protocol Buffers implementation for the Rust Language."
+documentation = "https://docs.rs/prost-derive"
+readme = "README.md"
+license = "Apache-2.0"
+repository = "https://github.com/tokio-rs/prost"
+
+[lib]
+proc_macro = true
+[dependencies.anyhow]
+version = "1"
+
+[dependencies.itertools]
+version = "0.10"
+
+[dependencies.proc-macro2]
+version = "1"
+
+[dependencies.quote]
+version = "1"
+
+[dependencies.syn]
+version = "1"
+features = ["extra-traits"]