summaryrefslogtreecommitdiffstats
path: root/third_party/rust/uniffi-example-sprites
diff options
context:
space:
mode:
Diffstat (limited to 'third_party/rust/uniffi-example-sprites')
-rw-r--r--third_party/rust/uniffi-example-sprites/.cargo-checksum.json1
-rw-r--r--third_party/rust/uniffi-example-sprites/Cargo.toml36
-rw-r--r--third_party/rust/uniffi-example-sprites/build.rs7
-rw-r--r--third_party/rust/uniffi-example-sprites/src/lib.rs65
-rw-r--r--third_party/rust/uniffi-example-sprites/src/sprites.udl22
-rw-r--r--third_party/rust/uniffi-example-sprites/tests/bindings/test_sprites.kts25
-rw-r--r--third_party/rust/uniffi-example-sprites/tests/bindings/test_sprites.py17
-rw-r--r--third_party/rust/uniffi-example-sprites/tests/bindings/test_sprites.rb22
-rw-r--r--third_party/rust/uniffi-example-sprites/tests/bindings/test_sprites.swift16
-rw-r--r--third_party/rust/uniffi-example-sprites/tests/test_generated_bindings.rs6
10 files changed, 217 insertions, 0 deletions
diff --git a/third_party/rust/uniffi-example-sprites/.cargo-checksum.json b/third_party/rust/uniffi-example-sprites/.cargo-checksum.json
new file mode 100644
index 0000000000..fac6b3ddfc
--- /dev/null
+++ b/third_party/rust/uniffi-example-sprites/.cargo-checksum.json
@@ -0,0 +1 @@
+{"files":{"Cargo.toml":"78f11927c8b2562a9975726e0ac20b51d124b6a21fdd633a9c0b1f0b69c5c788","build.rs":"84ba28d15fc0987d8efb5d523a643717c6b4b9b29570c0cc9cff81126ecfce7f","src/lib.rs":"857ae59f3194cb7fe117a308854bc793b2b56441e297bd0e327795fd435494da","src/sprites.udl":"bfd35f04ba0549301189dfb8fc45b0f39bad00956c324f33be0e845fb7ff78aa","tests/bindings/test_sprites.kts":"06ed115325f37ce59ed6f33e2d651cd2aa352fddcc644580f62a6da6ca075844","tests/bindings/test_sprites.py":"2e6ce838cfb387586257703c3500062438e840dd7ae57d185cdc244dc0745b8f","tests/bindings/test_sprites.rb":"6289a1833c7c8f4583ee4f0488d680de2ee46cfb203095a9b66d7234e2f07d53","tests/bindings/test_sprites.swift":"b2c0a6f4d5edfd7de7c2ba77b838865ffda153a6f364f273456175192d3e6e00","tests/test_generated_bindings.rs":"9a22d693c97fc6d90031cc60f61ece1d9279165ad6a92c9fe937448e126e8de6"},"package":null} \ No newline at end of file
diff --git a/third_party/rust/uniffi-example-sprites/Cargo.toml b/third_party/rust/uniffi-example-sprites/Cargo.toml
new file mode 100644
index 0000000000..6c55e9d88c
--- /dev/null
+++ b/third_party/rust/uniffi-example-sprites/Cargo.toml
@@ -0,0 +1,36 @@
+# THIS FILE IS AUTOMATICALLY GENERATED BY CARGO
+#
+# When uploading crates to the registry Cargo will automatically
+# "normalize" Cargo.toml files for maximal compatibility
+# with all versions of Cargo and also rewrite `path` dependencies
+# to registry (e.g., crates.io) dependencies.
+#
+# If you are reading this file be aware that the original Cargo.toml
+# will likely look very different (and much more reasonable).
+# See Cargo.toml.orig for the original contents.
+
+[package]
+edition = "2021"
+name = "uniffi-example-sprites"
+version = "0.22.0"
+authors = ["Firefox Sync Team <sync-team@mozilla.com>"]
+publish = false
+license = "MPL-2.0"
+
+[lib]
+name = "uniffi_sprites"
+crate-type = [
+ "lib",
+ "cdylib",
+]
+
+[dependencies.uniffi]
+path = "../../uniffi"
+
+[dev-dependencies.uniffi]
+path = "../../uniffi"
+features = ["bindgen-tests"]
+
+[build-dependencies.uniffi]
+path = "../../uniffi"
+features = ["build"]
diff --git a/third_party/rust/uniffi-example-sprites/build.rs b/third_party/rust/uniffi-example-sprites/build.rs
new file mode 100644
index 0000000000..858b8d1615
--- /dev/null
+++ b/third_party/rust/uniffi-example-sprites/build.rs
@@ -0,0 +1,7 @@
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this
+ * file, You can obtain one at http://mozilla.org/MPL/2.0/. */
+
+fn main() {
+ uniffi::generate_scaffolding("./src/sprites.udl").unwrap();
+}
diff --git a/third_party/rust/uniffi-example-sprites/src/lib.rs b/third_party/rust/uniffi-example-sprites/src/lib.rs
new file mode 100644
index 0000000000..7aa3741d19
--- /dev/null
+++ b/third_party/rust/uniffi-example-sprites/src/lib.rs
@@ -0,0 +1,65 @@
+/* This Source Code Form is subject to the terms of the Mozilla Public
+ * License, v. 2.0. If a copy of the MPL was not distributed with this
+ * file, You can obtain one at http://mozilla.org/MPL/2.0/. */
+
+use std::sync::RwLock;
+
+// A point in two-dimensional space.
+#[derive(Debug, Clone)]
+pub struct Point {
+ x: f64,
+ y: f64,
+}
+
+// A magnitude and direction in two-dimensional space.
+// For simplicity we represent this as a point relative to the origin.
+#[derive(Debug, Clone)]
+pub struct Vector {
+ dx: f64,
+ dy: f64,
+}
+
+// Move from the given Point, according to the given Vector.
+pub fn translate(p: &Point, v: Vector) -> Point {
+ Point {
+ x: p.x + v.dx,
+ y: p.y + v.dy,
+ }
+}
+
+// An entity in our imaginary world, which occupies a position in space
+// and which can move about over time.
+#[derive(Debug)]
+pub struct Sprite {
+ // We must use interior mutability for managing mutable state, hence the `RwLock`.
+ current_position: RwLock<Point>,
+}
+
+impl Sprite {
+ fn new(initial_position: Option<Point>) -> Sprite {
+ Sprite {
+ current_position: RwLock::new(initial_position.unwrap_or(Point { x: 0.0, y: 0.0 })),
+ }
+ }
+
+ fn new_relative_to(reference: Point, direction: Vector) -> Sprite {
+ Sprite {
+ current_position: RwLock::new(translate(&reference, direction)),
+ }
+ }
+
+ fn get_position(&self) -> Point {
+ self.current_position.read().unwrap().clone()
+ }
+
+ fn move_to(&self, position: Point) {
+ *self.current_position.write().unwrap() = position;
+ }
+
+ fn move_by(&self, direction: Vector) {
+ let mut current_position = self.current_position.write().unwrap();
+ *current_position = translate(&current_position, direction)
+ }
+}
+
+include!(concat!(env!("OUT_DIR"), "/sprites.uniffi.rs"));
diff --git a/third_party/rust/uniffi-example-sprites/src/sprites.udl b/third_party/rust/uniffi-example-sprites/src/sprites.udl
new file mode 100644
index 0000000000..6781c6cee5
--- /dev/null
+++ b/third_party/rust/uniffi-example-sprites/src/sprites.udl
@@ -0,0 +1,22 @@
+
+namespace sprites {
+ Point translate([ByRef] Point position, Vector direction);
+};
+
+dictionary Point {
+ double x;
+ double y;
+};
+
+dictionary Vector {
+ double dx;
+ double dy;
+};
+
+interface Sprite {
+ constructor(Point? initial_position);
+ [Name=new_relative_to] constructor(Point reference, Vector direction);
+ Point get_position();
+ void move_to(Point position);
+ void move_by(Vector direction);
+};
diff --git a/third_party/rust/uniffi-example-sprites/tests/bindings/test_sprites.kts b/third_party/rust/uniffi-example-sprites/tests/bindings/test_sprites.kts
new file mode 100644
index 0000000000..42451f28dd
--- /dev/null
+++ b/third_party/rust/uniffi-example-sprites/tests/bindings/test_sprites.kts
@@ -0,0 +1,25 @@
+import uniffi.sprites.*;
+
+val sempty = Sprite(null)
+assert( sempty.getPosition() == Point(0.0, 0.0) )
+
+val s = Sprite(Point(0.0, 1.0))
+assert( s.getPosition() == Point(0.0, 1.0) )
+
+s.moveTo(Point(1.0, 2.0))
+assert( s.getPosition() == Point(1.0, 2.0) )
+
+s.moveBy(Vector(-4.0, 2.0))
+assert( s.getPosition() == Point(-3.0, 4.0) )
+
+s.destroy()
+try {
+ s.moveBy(Vector(0.0, 0.0))
+ assert(false) { "Should not be able to call anything after `destroy`" }
+} catch(e: IllegalStateException) {
+ assert(true)
+}
+
+val srel = Sprite.newRelativeTo(Point(0.0, 1.0), Vector(1.0, 1.5))
+assert( srel.getPosition() == Point(1.0, 2.5) )
+
diff --git a/third_party/rust/uniffi-example-sprites/tests/bindings/test_sprites.py b/third_party/rust/uniffi-example-sprites/tests/bindings/test_sprites.py
new file mode 100644
index 0000000000..5142c2fc42
--- /dev/null
+++ b/third_party/rust/uniffi-example-sprites/tests/bindings/test_sprites.py
@@ -0,0 +1,17 @@
+from sprites import *
+
+sempty = Sprite(None)
+assert sempty.get_position() == Point(0, 0)
+
+s = Sprite(Point(0, 1))
+assert s.get_position() == Point(0, 1)
+
+s.move_to(Point(1, 2))
+assert s.get_position() == Point(1, 2)
+
+s.move_by(Vector(-4, 2))
+assert s.get_position() == Point(-3, 4)
+
+srel = Sprite.new_relative_to(Point(0, 1), Vector(1, 1.5))
+assert srel.get_position() == Point(1, 2.5)
+
diff --git a/third_party/rust/uniffi-example-sprites/tests/bindings/test_sprites.rb b/third_party/rust/uniffi-example-sprites/tests/bindings/test_sprites.rb
new file mode 100644
index 0000000000..9d79b57026
--- /dev/null
+++ b/third_party/rust/uniffi-example-sprites/tests/bindings/test_sprites.rb
@@ -0,0 +1,22 @@
+# frozen_string_literal: true
+
+require 'test/unit'
+require 'sprites'
+
+include Test::Unit::Assertions
+include Sprites
+
+sempty = Sprite.new(nil)
+assert_equal sempty.get_position, Point.new(0, 0)
+
+s = Sprite.new(Point.new(0, 1))
+assert_equal s.get_position, Point.new(0, 1)
+
+s.move_to(Point.new(1, 2))
+assert_equal s.get_position, Point.new(1, 2)
+
+s.move_by(Vector.new(-4, 2))
+assert_equal s.get_position, Point.new(-3, 4)
+
+srel = Sprite.new_relative_to(Point.new(0, 1), Vector.new(1, 1.5))
+assert_equal srel.get_position, Point.new(1, 2.5)
diff --git a/third_party/rust/uniffi-example-sprites/tests/bindings/test_sprites.swift b/third_party/rust/uniffi-example-sprites/tests/bindings/test_sprites.swift
new file mode 100644
index 0000000000..d5428ac679
--- /dev/null
+++ b/third_party/rust/uniffi-example-sprites/tests/bindings/test_sprites.swift
@@ -0,0 +1,16 @@
+import sprites
+
+let sempty = Sprite(initialPosition: nil)
+assert( sempty.getPosition() == Point(x: 0, y: 0))
+
+let s = Sprite(initialPosition: Point(x: 0, y: 1))
+assert( s.getPosition() == Point(x: 0, y: 1))
+
+s.moveTo(position: Point(x: 1.0, y: 2.0))
+assert( s.getPosition() == Point(x: 1, y: 2))
+
+s.moveBy(direction: Vector(dx: -4, dy: 2))
+assert( s.getPosition() == Point(x: -3, y: 4))
+
+let srel = Sprite.newRelativeTo(reference: Point(x: 0.0, y: 1.0), direction: Vector(dx: 1, dy: 1.5))
+assert( srel.getPosition() == Point(x: 1.0, y: 2.5) )
diff --git a/third_party/rust/uniffi-example-sprites/tests/test_generated_bindings.rs b/third_party/rust/uniffi-example-sprites/tests/test_generated_bindings.rs
new file mode 100644
index 0000000000..00dd779d68
--- /dev/null
+++ b/third_party/rust/uniffi-example-sprites/tests/test_generated_bindings.rs
@@ -0,0 +1,6 @@
+uniffi::build_foreign_language_testcases!(
+ "tests/bindings/test_sprites.py",
+ "tests/bindings/test_sprites.rb",
+ "tests/bindings/test_sprites.kts",
+ "tests/bindings/test_sprites.swift",
+);